getAttribute returns value with upper-case first letter

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED INVALID
17 years ago
9 years ago

People

(Reporter: Kevin Cook, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When I use getAttribute to test a value, the result has an upper-case first
letter ("Center" instead of "center").  I'm not sure if this is a bug or not (I
couldn't find the official rule on this) but it doesn't seem right that the test
would fail because I'm only testing for lower-case values.


I'm using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001019 .

Comment 1

17 years ago
Yep, I can't find a statement that says this should be in mixed-case (and this 
would be a pain for script authors). 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
According to the second-to-last paragraph in section 1.5.1 in the DOM HTML spec
at http://www.w3.org/TR/DOM-Level-2-HTML/html.html#ID-642250288 mozilla does the
right thing, it generalizes the attribute values so that they're always the same
regardless of how the user sets them. Marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Component: DOM Level 1 → DOM Core

Comment 3

17 years ago
QA contact Update
QA Contact: janc → desale

Comment 4

17 years ago
VERIFIED invalid
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: desale → general
You need to log in before you can comment on or make changes to this bug.