Status

SeaMonkey
General
P3
normal
RESOLVED INVALID
18 years ago
13 years ago

People

(Reporter: Misha Brukman, Unassigned)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Going to this page renders <h1> fonts in a RIDICULOUSLY large font size.
pressing refresh does not help, the entire body text region is written in a HUGE
font size. the url is the example, i haven't seen it anywhere else.

Sorry, I didn't see "text rendering" as a component and I don't think it's a
parser problem, more of a display, but then I wouldn't really know that either.
maybe "DOM to text conversion"? but again, I'm not so sure, sorry.

This is Mozilla/5.0 (X11; U; Linux 2.2.9 i686; en-US; m18) Gecko/20001010 .

Comment 1

18 years ago
myb2: how is your X setup configured? Do you have additional (i.e.,
non-standard) fonts set up? Are you using truetype support? I can't duplicate
this on my setup (Debian Woody with xfstt and many, many extra fonts), so as
many details as possible on your setup would be a good thing.

Comment 2

18 years ago
It may be faster to do
  NS_FONT_DEBUG=3 ./mozilla URL
and see what Mozilla actually loads.

Comment 3

18 years ago
over to Erik
Assignee: asa → erik

Comment 4

18 years ago
Yes, please set an environment variable called NS_FONT_DEBUG to the value 3 and
then run the app. Let me know which fonts are being loaded.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future
(Reporter)

Comment 5

18 years ago
I do not have any extra fancy fonts. I run xfs, not xfstt. This is Redhat 6.0 .
Running with NS_FONT_DEBUG = 3, and opening the amiga URL I get:

-------

FindFont(0061)[serif, ]
returns -adobe-times-medium-r-normal--17-120-100-100-p-84-iso8859-1
Document about:blank loaded successfully
FindFont(0061)[helvetica, ]
returns -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
FindFont(0061)[helvetica, ]
returns -adobe-helvetica-medium-r-normal--10-100-75-75-p-56-iso8859-1
->>>>>>>>>>>>>> Write Clipboard to memory
->>>>>>>>>>>>>> Read Clipboard from memory
FindFont(0061)[serif, ]
returns -adobe-times-medium-r-normal--17-120-100-100-p-84-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-medium-r-normal--17-120-100-100-p-84-iso8859-1
FindFont(0061)[tahoma, arial, helvetica, ]
returns -ult1mo-arial-medium-r-normal--13-*-*-*-p-*-iso8859-2
FindFont(0061)[tahoma, arial, helvetica, ]
returns -ult1mo-arial-bold-r-normal--13-*-*-*-p-*-iso8859-2
FindFont(0061)[tahoma, arial, helvetica, ]
returns -ult1mo-arial-medium-r-normal--13-*-*-*-p-*-iso8859-2
FindFont(0061)[serif, ]
returns -adobe-times-bold-r-normal--34-240-100-100-p-177-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-bold-r-normal--64-*-*-*-p-*-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-bold-i-normal--64-*-*-*-p-*-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-bold-r-normal--64-*-*-*-p-*-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-bold-r-normal--24-240-75-75-p-132-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-bold-r-normal--48-*-*-*-p-*-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-bold-r-normal--34-240-100-100-p-177-iso8859-1
FindFont(0061)[serif, ]
returns -adobe-times-medium-r-normal--10-100-75-75-p-54-iso8859-1
FindFont(0061)[tahoma, arial, ]
returns -ult1mo-arial-medium-r-normal--13-*-*-*-p-*-iso8859-2
FindFont(0061)[tahoma, arial, ]
returns -ult1mo-arial-bold-r-normal--13-*-*-*-p-*-iso8859-2
FindFont(0061)[tahoma, ariel, helvetica, ]
returns -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
FindFont(0061)[tahoma, ariel, helvetica, ]
returns -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
FindFont(0061)[tahoma, ariel, helvetica, ]
returns -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
FindFont(0061)[tahoma, arial, helvetica, ]
returns -ult1mo-arial-bold-r-normal--13-*-*-*-p-*-iso8859-2
FindFont(0061)[tahoma, arial, ]
returns -ult1mo-arial-medium-r-normal--13-*-*-*-p-*-iso8859-2
Document http://www.amiga.com/feature/about_amiga/about_amiga.shtml loaded
successfully

------

Hope that helps. Sorry for the long delay.
(Reporter)

Comment 6

18 years ago
Let me help with a visual demonstration:
http://www.people.cornell.edu/pages/myb2/mozilla/large_fonts.png
shows you exactly what I see when I visit that page. Mind you, the rest of the
web renders great.

The image is 1272x945, 62k PNG.

Comment 7

18 years ago
I'm sorry but I suspect our answer is that you should get a font server that 
can scale fonts eg xfstt.
(Reporter)

Comment 8

18 years ago
I don't think it's xfs, but I installed xfstt anyway, and it doesn't help.

Here's why I think it's Mozilla though:

I go to the url
http://www.amiga.com/feature/about_amiga/about_amiga.shtml
Result: HUGE fonts. I click on the first link on the left side,
"The Next Computing Revolution". Fonts are looking good. Right size. Great.
I click "Back". Normally, you'd expect huge fonts, right? But no, fonts are
sized properly this time (!). And now, for the final trick, I press the "Reload"
button (now I'm on the url mentioned above), and BAM! fonts are back as they are
in the screenshot, out of proportion.

Does that help at all?

Comment 9

17 years ago
reassign to bstell and keep it as future
Assignee: erik → bstell
Status: ASSIGNED → NEW

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 10

17 years ago
works fine for me.

PC, SuSE 7.0 Professional Version, no personal or other configuration hacks,

build 2001040608

Comment 11

17 years ago
--> ftang
Assignee: bstell → ftang
Status: ASSIGNED → NEW

Comment 12

17 years ago
bulk move NEW FUTURE bug to ASSIGN
Status: NEW → ASSIGNED
Product: Browser → Seamonkey

Comment 13

13 years ago
-> to defaul owner
Assignee: ftang → general
Status: ASSIGNED → NEW
QA Contact: doronr → general

Comment 14

13 years ago
myb2@cornell.edu - 20001010 is too old a 
build to report bugs against now. The problem you are reporting may well have 
been fixed already. 

Could you please download a recent nightly build from 
<http://www.mozilla.org/releases/nightly.html>, and then let us know if you 
still see this problem?

Thanks,
Joel Nackman
(Reporter)

Comment 15

13 years ago
Quoting Joel:
> 20001010 is too old a build to report bugs against now. 

Au contraire, I originally *reported* the bug on 2000/10/19; my report hasn't
been acknowledged as a bug in 4+ years.

> The problem you are reporting may well have been fixed already.
> Could you please download a recent nightly build from [URL], and then let us 
> know if you still see this problem?

Most likely, it has been fixed. However, I cannot check the URL anymore because
Amiga has reorganized their website, so this page is gone (note to self: attach
test cases in the future), I no longer run RedHat 6.0 (yes, it's really been 4
years), and I use Firefox these days (which isn't strictly "Mozilla").

As such, I'm marking this bug `INVALID'.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.