forums.views.reply() should require POST method

VERIFIED FIXED in 2.9

Status

P4
trivial
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: erik, Assigned: tgavankar)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Shouldn't forums.views.reply be decorated @require_POST? I don't think we ever throw GETs at it, and similar views like lock_thread() are @require_POST.

Note that it isn't hurting anything at present; it falls back to returning a list of posts, with a form error, on GET.
Duplicate of this bug: 583090
Target Milestone: --- → 2011Q2
Assignee: nobody → tgavankar
(Assignee)

Comment 2

7 years ago
Fixed and added a test at https://github.com/jsocol/kitsune/commit/5f4b53d6
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: 2011Q2 → 2.9
Please add STR- I'm unsure how to verify this.  After reading the related bug I tried this link: https://support-release.allizom.org/fr/questions/775683/reply
But it did not redirect.
It shouldn't redirect, it should return HTTP 405
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.