window.open opens multiple windows with the same window name

VERIFIED FIXED in M9

Status

()

Core
DOM: Core & HTML
P1
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: gerardok, Assigned: Dan M)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: QA BLOCKER - Blocking QA automation)

(Reporter)

Description

19 years ago
Project: Seamonkey
Program: Apprunner.exe
BuildID: 1999-04-29-08
Platform: WinNT

If you have an window named FooWin, window.open("URL", "FooWin") fails to locate
that window and it opens a new window with the same name instead.

The same failure is happening on Win32, MacOS and possibly on Linux. Viewer.exe
doesn't show that failure.

Steps to reproduce:
1. Create an HTML file with the following content:

<HTML>
<HEAD>
<TITLE>test.html</TITLE>
</HEAD>
<BODY>
<SCRIPT type="text/javascript">
window.open("http://bubblegum", "FooWin");
window.open("http://slip", "FooWin");
</SCRIPT>
</BODY>
</HTML>

2. Load that file in apprunner

Actual Results: It opens two child windows.
Expected results: A single child window opened with the homepage from slip
server displayed in it.
(Reporter)

Updated

19 years ago
Priority: P3 → P1
QA Contact: 4616 → 4015
Whiteboard: QA BLOCKER

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6

Comment 1

19 years ago
Sorry.  There's no way this can happen by M5.  In order to iterate over all open
windows, I have a dependency on David Matiskella's window manager.  Until that
lands, this bug is dead in the water.

Setting Target Milestone to M6, since I'm assuming that the window manager is
slated to go in some time before M6 closes.

Updated

19 years ago
Severity: major → blocker
Whiteboard: QA BLOCKER → QA BLOCKER - Blocking QA automation

Updated

19 years ago
Target Milestone: M6 → M8

Comment 2

19 years ago
window.open doesn't even work on Mac and Linux.  It won't before necko
lands.  Moving off to M8.

Updated

19 years ago
Assignee: hyatt → danm
Status: ASSIGNED → NEW

Comment 3

19 years ago
Giving this to danm.  Basically our FindBlahByName method in nsWebShellWindow
needs to know how to look over the window list.

Comment 4

19 years ago
*** Bug 8831 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
now checking for webshell names among list of open windows.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Verified on 1999-07-01-08-M8 build.
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 7

19 years ago
The same failure is happening in M9 builds. It was working fine on the released
M8 build. Re-tested bug on 07/27 and 07/22 Apprunner. Bug reopened.
(Reporter)

Updated

19 years ago
Status: REOPENED → NEW
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---

Updated

19 years ago
Target Milestone: M8 → M9

Comment 8

19 years ago
Moving from M8 to M9 due to reopen!
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
Hmmm.  Someone broke the window lookup-by-name code, middle of July.  That's been fixed
and this bug seems gone once again.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

19 years ago
Verified on 1999-08-13-09-M9 build.
You need to log in before you can comment on or make changes to this bug.