Closed Bug 573012 Opened 12 years ago Closed 12 years ago

Disk cache gets deleted when Firefox restart after quit from Dock menu.

Categories

(Core :: Networking: Cache, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 105843

People

(Reporter: illusionmist62442, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre

When I quit Firefox (in this case Minefield) and restart it I found all the disk cache gone! I've seen other bugs about this only that they always happen after Firefox's crashed.

It took me a while to figure out that this only happens when I quit Minefield by selecting "Quit" from the menu of the Minefield item on the Dock. It doesn't happen if I quit it by Minefield's own menubar or hotkey.

So I'm guessing that Firefox "misunderstands" itself crashed when it's Dock that closes it?


Reproducible: Always

Steps to Reproduce:
1. Launch Firefox.
2. Select "Quit" from the Dock menu.
3. Restart Firefox.

Actual Results:  
Upon restart all the cache will be cleared.


Expected Results:  
Leave the cache alone will ya? ;)
Attached image The Dock menu options.
generally quitting from the dock does result in a crash/abort because we haven't managed to get the message from the dock to wind through gecko safely so that it can cleanup.

I suspect the only way for it to work would be for all gecko task work to *not* be in the ui thread (thus we wouldn't have call stacks that we couldn't unwind).

helpwanted (if you're interested).

this is a known limitation (dupeme). i suspect to some extent, out of process geckos will mostly make this problem go away (if the cache is managed by a process which isn't the primary ui app).
Whiteboard: DUPEME
Related:
Bug 384284 - Quitting from the dock leaks domwindows
Bug 105843 - Cache lost if Mozilla crashes
I wonder if we can get away with just not clearing the cache in this case, even if we can't fix the unwinding or make the cache survive unclean shutdowns in general.
Yeah, it sounds like "quit" from the Dock (which isn't our Menu; it's an operating system menu) doesn't send the app a message saying "please quit" but rather just kills it off without giving it a chance to save things, etc...  It's _very_ different from selecting "Quit" from the menu.

Jesse, I don't think we can fix the cache situation here without making cache survive unclean shutdown in general.
Depends on: 105843
Summary: Disk cache gets deleted when Firefox restart after quit from Dock option. → Disk cache gets deleted when Firefox restart after quit from Dock menu.
This is a dupe of bug 105843, based on comment 5.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
No longer depends on: 105843
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 105843
You need to log in before you can comment on or make changes to this bug.