Toolbar Options missing using "Edit As New" from "SENT" or "DRAFTS" folders

RESOLVED DUPLICATE of bug 78794

Status

Thunderbird
Toolbars and Tabs
RESOLVED DUPLICATE of bug 78794
8 years ago
6 years ago

People

(Reporter: rsmurphey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0.5

Toolbar options for "Insert" and "Format" disappear from the top toolbar when "Edit As New" is selected for a message in the "SENT" or "DRAFTS" folders. They are also missing from the "Customize" toolbar options. 

"Insert" and "Format" are present in the top toolbar when "Writing a New Message", as well as when selecting "Edit As New" for any message in the "INBOX".

Problem is repeatable and consistent whether using "right mouse click" to "Edit As New" or toolbar routing via "Message" > "Edit As New". Obvious difference exists in set-up consistency, using "Edit As New", among various mail folders.


Reproducible: Always

Steps to Reproduce:
1.Select message in "Sent" or Drafts" folder
2.Select "Edit As New" via mouse or top toolbar
3. 
Actual Results:  
Top toolbar loses "Insert" & "Format" options.

Expected Results:  
Top toolbar ("File, Edit, View, Insert, Format, Message, Options, Tools, Help, etc. ) should remain consistent when "Write" or "Edit As New" actions are being taken.
Those options disappear when the message you edit as new is a plain text message. You get the plain text compose window, which doesn't have insert or format options...
(Reporter)

Comment 2

8 years ago
Thanks o.e.ekker for the comment/reply. Still, the software design appears inconsistent if a message is being "edited as new" and all "new" messages are set (toggled) in the 'account settings' to be "composed in HTML", that the "Insert" and "Format" features would be overridden and disappear. 

Additionally, ...previously, virtually all of my messages in the drafts, or sent folders behaved similarly, the latest version of T-Bird is demonstrating the message type (text vs. html) discrimination you describe.

Thanks again.

Comment 3

8 years ago
I can confirm the bug on the Mac OS and it is quite annoying.  I have not had the problem on earlier versions on my Windows machines.

Forbes Dewey

Comment 4

8 years ago
Hey chaps, this was first mentioned in bug 401900, raised on 31/10/2007, still present in 3.0.8. Message was plain text and "compose in HTML" is NOT set.
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Hey chaps, this was first mentioned in bug 401900, raised on 31/10/2007, still
> present in 3.0.8. Message was plain text and "compose in HTML" is NOT set.

Graeme,
Sorry, but  the previous bug does not apply.  The "Compose in HTML" flag was/is set (checked) when the problem occurred.
(In reply to rsmurphey from comment #2)
> Thanks o.e.ekker for the comment/reply. Still, the software design appears
> inconsistent if a message is being "edited as new" and all "new" messages
> are set (toggled) in the 'account settings' to be "composed in HTML", that
> the "Insert" and "Format" features would be overridden and disappear. 

Per reporter's comment 2, this is a duplicate of Bug 78794.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 78794
You need to log in before you can comment on or make changes to this bug.