ASSERTION: Should have positive frame time: 'videoData->mTime >= mStartTime'

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: bz, Unassigned)

Tracking

({assertion, intermittent-failure})

Trunk
x86
Mac OS X
assertion, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I ran into this assert when running something totally unrelated on try server.  It fired during the running of layout/generic/crashtests/493111-1.html, which doesn't even include any video stuff...
Oh, and the file+line, on a build from yesterday, is:

file /builds/slave/tryserver-linux-debug/build/content/base/src/nsContentUtils.cpp, line 2719

Updated

8 years ago
Blocks: 573311
And hit on SeaMonkey Cd in a test that also does not have any video stuff [crashtests/489462-1.html].

###!!! ASSERTION: Should have positive frame time: 'videoData->mTime >= mStartTime', file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/media/nsBuiltinDecoderStateMachine.cpp, line 1115
gklayout!nsBuiltinDecoderStateMachine::Run+0x00000000000003E0 (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\content\media\nsbuiltindecoderstatemachine.cpp, line 807)
xpcom_core!nsThread::ProcessNextEvent+0x00000000000001FA (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\xpcom\threads\nsthread.cpp, line 547)
xpcom_core!NS_ProcessNextEvent_P+0x0000000000000053 (e:\builds\slave\comm-central-trunk-win32-debug\build\objdir\mozilla\xpcom\build\nsthreadutils.cpp, line 250)
xpcom_core!nsThread::ThreadFunc+0x00000000000000CE (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\xpcom\threads\nsthread.cpp, line 263)
nspr4!_PR_NativeRunThread+0x00000000000000DB (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\nsprpub\pr\src\threads\combined\pruthr.c, line 426)
nspr4!pr_root+0x0000000000000019 (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\nsprpub\pr\src\md\windows\w95thred.c, line 122)

Updated

8 years ago
Duplicate of this bug: 571110

Updated

8 years ago
Duplicate of this bug: 570142

Updated

8 years ago
Duplicate of this bug: 573311

Comment 6

8 years ago
This orange is hard-to-star because it happens after the video-using crashtest has finished.
Blocks: 438871
No longer blocks: 573311
Whiteboard: [orange]
Keywords: assertion
This assertion still exists, but presumably hasn't caused test orange for a long time.  Marking this WFM on the assumption that a bug fix solved this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.