Message notification not happening with IMAP (exchange, ugh) and filters

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
10 months ago

People

(Reporter: mark.richards, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2018-01-20])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

A new message received in an IMAP mailbox with filters that move received messages to other folders will not trigger a notification (either a sound or setting the folder to bold).  Once I mouseclick on the destination folder the message/s immediately show and the folder changes to bold.

Reproducible: Always

Steps to Reproduce:
1. Set up a filter that moves an inbound message in an IMAP account to another folder
2. Send a message 
3.


Expected Results:  
Message notification should trigger and produce expected results
(Reporter)

Comment 1

9 years ago
This does NOT happen on my own IMAP server running on Linux (dovecot).
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters

Comment 2

8 years ago
Mark, do you still see this in version 3.1.7
(Reporter)

Comment 3

8 years ago
Still present in 3.1.7 here.

Notifications are turned on but they don't trigger an action when mail is processed through a mailbox filter.

However the destination folder does get updated such that it changes to a bold font.

Also, FWIW, I tried using the Mailbox Alert extension.  No change in behaviour.
(Reporter)

Comment 4

6 years ago
TB Version 13.0.1

Still does not trigger notification, with and without a filter.

Comment 5

10 months ago
Hi Mark. Does this still happen for you when using current version?
Flags: needinfo?(mark.richards)
Whiteboard: [closeme 2018-01-20]
(Reporter)

Comment 6

10 months ago
As this issue received first attention about a year after it was first posted, the infrastructure in which it manifested had long since changed.

In the current TB version I'm running: 52.5.2 (32-bit) the issue I reported is not happening.

Therefore this can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(mark.richards)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.