Can't send page to email/safari until page has finished loading

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: jruderman, Assigned: st3fan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I can't toss the page to safari until after the page has finished loading.  This means I have to wait a long time and then load the page a second time!

(Firefox Home b13 on iPhone 3G)

Comment 1

8 years ago
I have no choice in this.  The UIWebView does not have the URL of the page until it finishes loading.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

8 years ago
So?  Firefox Home has the URL; it just handed it to WebKit!
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

Comment 3

8 years ago
Only for the original url you chose form FFH.  If you have navigated anywhere, I don't see that url until that page has loaded.  Emailing the incorrect url is worse than making you wait.
(Reporter)

Comment 4

8 years ago
Hmm, but not navigating anywhere is a pretty common case.  Is it possible to detect whether you've navigated anywhere?  Or make it work for the first 5 seconds?

Comment 5

8 years ago
Moving FFHome-related bugs to new component -> Firefox Home
Component: Experimental Clients → Firefox Home
QA Contact: experimental.clients → firefox-home
I think this is definitely a must have. In every "WebView" app, I choose "Open in Safari" and go back to the app, doing what I have to while letting Safari download the page in the background.

Twitter for iPhone can update the URL as soon as possible, so there is a solution here. You can see it when clicking on bit.ly links. Open and close the "Export" menu a lot of times.

Updated

8 years ago
Depends on: 578805
(Assignee)

Updated

8 years ago
Duplicate of this bug: 598362

Updated

8 years ago
Assignee: nobody → stefan
The Firefox Home project has been retired, and Mozilla will no longer invest in future work on this project [1]. All bugs related to Firefox Home are being mass resolved.

For those interested in continuing work on this app, the source code for Firefox Home is available on Github [2].

[1] http://blog.mozilla.org/services/2012/08/31/retiring-firefox-home/
[2] https://github.com/mozilla-services/ios-sync-client
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.