The browser gets crashed in classic skin when try to log on www.silverceekonline.com

VERIFIED DUPLICATE of bug 76119

Status

()

Core
ImageLib
P3
normal
VERIFIED DUPLICATE of bug 76119
18 years ago
17 years ago

People

(Reporter: Patty Mac, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
mozilla0.9.1
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib], URL)

(Reporter)

Description

18 years ago
Platform: Linux only, Build: 2000-10-19-09-MN6).

Steps to reproduce:

1. Launch Netscape 6
2. Go to Edit/Preferences/Themes/Classic 
3. Type on the url: www.silvercreekonline.com
4. The browser get crashed.
NOTE: Always reproducible. Work fine in modern skin.

Comment 1

18 years ago
Worksforme with the same build on Linux.

Comment 2

18 years ago
Patty can you try this again on a later build?  junruh reports that it works on 
the same build on Linux so we should have another test reproducable case.
(Reporter)

Comment 3

18 years ago
Paul, I just try on Linux (2000-10-23-09-MN6), the browser gets crashed again.
This time, the browser gets crashed in both modern and classic skin.
However, on the build (2000-10-19-09-MN6), the browser gets crashed in classic
skin only, but not in modern skin. 

Steps to reproduce:

1. gunzip *.gz
2. tar -xvf *.tar
3. cd package
4. ./netscape
5. When the browser launches, type on the url: www.silvercreekonline.com
NOTE: The browsers get crashed.  

Follow exactly like the above procedures, the browser gets crashed on 
Linux (2000-10-23-09-MN6) and (2000-10-19-09-MN6) as well.
(Reporter)

Comment 4

18 years ago
Paul, I just want to add more info in this bug. I just verify the 
installer, not the tar file (2000-10-23-09-MN6), the browser gets carshed in
both modern and classic skin.

Updated

17 years ago
Keywords: crash

Comment 5

17 years ago
Data Point:
Trying it out with build 2000122121 Linux (the SEA):
Site crashes with Classic and Modern, but *not* with ThinIce (gotten from
x.themes.org).

Comment 6

17 years ago
Sending to Hewitt.
Assignee: hangas → hewitt

Comment 7

17 years ago
This shouldn't have anything to do with themes - the crash is caused by
something on that page. Over to layout.
Assignee: hewitt → clayton
Component: Themes → Layout
QA Contact: pmac → petersen

Comment 8

17 years ago
I'm able to reproduce with the 2001010808 Linux build.

Steps to reproduce:

1) Go to url. Page's frameset should load and display fine.

2) Press the reload button on toolbar. The crash should occur.

Comment 9

17 years ago
Here's the call stack via talkback:

 Call Stack:     (Signature = 0x6d6f632e 09761693)
     0x6d6f632e
     IL_DestroyImage()
     ImageRequestImpl::~ImageRequestImpl()
     ImageRequestImpl::Release()
     nsFrameImageLoader::StopImageLoad()
     nsPresContext::Stop()
     DocumentViewerImpl::Stop()
     nsDocShell::Stop()
     nsDocShell::Destroy()
     nsWebShell::Destroy()
     nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame()
     nsFrame::Destroy()
     nsFrameList::DestroyFrames()
     nsContainerFrame::Destroy()
     nsFrameList::DestroyFrames()
     nsContainerFrame::Destroy()
     nsLineBox::DeleteLineList()
     nsBlockFrame::Destroy()
     nsFrameList::DestroyFrames()
     nsContainerFrame::Destroy()
     nsFrameList::DestroyFrames()
     nsContainerFrame::Destroy()
     ViewportFrame::Destroy()
     FrameManager::~FrameManager()
     FrameManager::Release()
     PresShell::~PresShell()
     PresShell::Release()
     nsCOMPtr_base::~nsCOMPtr_base()
     DocumentViewerImpl::~DocumentViewerImpl()
     DocumentViewerImpl::Release()
     nsCOMPtr_base::assign_with_AddRef()
     nsDocShell::SetupNewViewer()
     nsWebShell::SetupNewViewer()
     nsDocShell::Embed()
     nsWebShell::Embed()
     nsDocShell::CreateContentViewer()
     nsDSURIContentListener::DoContent()
     nsDocumentOpenInfo::DispatchContent()
     nsDocumentOpenInfo::OnStartRequest()
     nsHTTPFinalListener::OnStartRequest()
     nsHTTPCacheListener::OnStartRequest()
     nsDiskCacheRecordChannel::OnStartRequest()
     nsOnStartRequestEvent::HandleEvent()
     nsStreamListenerEvent::HandlePLEvent()
     PL_HandleEvent()
     PL_ProcessPendingEvents()
     nsEventQueueImpl::ProcessPendingEvents()
     event_processor_callback()
     our_gdk_io_invoke()
     libglib-1.2.so.0 + 0xeaca (0x40627aca)
     libglib-1.2.so.0 + 0x10186 (0x40629186)
     libglib-1.2.so.0 + 0x10751 (0x40629751)
     libglib-1.2.so.0 + 0x108f1 (0x406298f1)
     libgtk-1.2.so.0 + 0x8c5b9 (0x4054e5b9)
     nsAppShell::Run()
     nsAppShellService::Run()
     main1()
     main()
     libc.so.6 + 0x189cb (0x4023f9cb)

Comment 10

17 years ago
I can't reproduce this problem on either Mac (20010808) or Windows (2001010804)
If the crash is in IL_DestroyImage, then let's move this to ImageLib.
Assignee: clayton → pnunn
Component: Layout → ImageLib
QA Contact: petersen → tpreston

Updated

17 years ago
Target Milestone: --- → mozilla0.9.1

Comment 12

17 years ago
this is a dupe, but I don't have the dupe number.
1x1 tracker image bug.
Status: NEW → ASSIGNED

Comment 13

17 years ago
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Assignee: pnunn → pavlov
Status: ASSIGNED → NEW

Comment 14

17 years ago
This is still a crasher with new imagelib, changing status whiteboard to 
[imglib], will try to get stack trace
Whiteboard: [imglib]

Comment 15

17 years ago
Call Stack, linux build 2001041205

   libimglib2.so + 0x392d (0x4112092d) 
   libimggif.so + 0x28d5 (0x4113e8d5) 
   libimggif.so + 0x1fe9 (0x4113dfe9) 
   libimggif.so + 0x270f (0x4113e70f) 
   libimggif.so + 0x26ce (0x4113e6ce) 
   libxpcom.so + 0x6a1c3 (0x400ae1c3) 
   libimggif.so + 0x2747 (0x4113e747) 
   libimglib2.so + 0x5e0d (0x41122e0d) 
   libnecko.so + 0x60b8e (0x408abb8e) 
   libnecko.so + 0x39e4d (0x40884e4d) 
   libnecko.so + 0x5fa3e (0x408aaa3e) 
   libnecko.so + 0x1d81e (0x4086881e) 
   libnecko.so + 0x1d0f8 (0x408680f8) 
   libxpcom.so + 0x7aa77 (0x400bea77) 
   libxpcom.so + 0x7a996 (0x400be996) 
   libxpcom.so + 0x7b879 (0x400bf879) 
   libwidget_gtk.so + 0xd643 (0x404f6643) 
   libwidget_gtk.so + 0xd3bd (0x404f63bd) 
   libglib-1.2.so.0 + 0xeaca (0x40688aca) 
   libglib-1.2.so.0 + 0x10186 (0x4068a186) 
   libglib-1.2.so.0 + 0x10751 (0x4068a751) 
   libglib-1.2.so.0 + 0x108f1 (0x4068a8f1) 
   libgtk-1.2.so.0 + 0x8c5b9 (0x405b25b9) 
   libwidget_gtk.so + 0xdb3c (0x404f6b3c) 
   libnsappshell.so + 0xddca (0x4038edca) 
   mozilla-bin + 0x54f4 (0x0804d4f4) 
   mozilla-bin + 0x5d85 (0x0804dd85) 
   libc.so.6 + 0x189cb (0x401ea9cb)
(Assignee)

Comment 16

17 years ago
marking as a dup of 76119 which has a much easier testcase (single image).  i've 
fixed the crash, now it asserts twice but shouldn't crash.

*** This bug has been marked as a duplicate of 76119 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
I crashed on w2k build 2001050204 , re-opening
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 19

17 years ago
its still a dup.  saari checked in a fix today for the crash.

*** This bug has been marked as a duplicate of 76119 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
Alrighty then, verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.