Warning: Unresponsive Script: [Script: file:///I:/Program%20Files/Siber%20Systems/AI%20RoboForm/Firefox/components/rfhelper.js:129] roboform

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: jim, Unassigned)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

I sent this first to Roboform.com support:

This "Warning"message is a huge nuisance. In certain situations while online. I think mostly when I'm working with online images and image editing programs...it pops up about every 20 seconds. Is there anything I can do to prevent it (or turn it off)?

Warning: Unresponsive Script:

A script on this page may be busy, or it may have stopped responding. You can stop the script now,
or you can continue to see if the script will complete.

Script: file:///I:/Program%20Files/Siber%20Systems/AI%20RoboForm/Firefox/components/rfhelper.js:129

STOP CONTINUE
*********************************************************

Roboform support response was this:

When Roboform script (rfhelper.js) uses hanged JS Context, Firefox will point to rfhelper.js as unresponsive script.
But it should point to script that actually hang.
So it is a Firefox bug.
Unfortunately we cannot do anything with that.

Reproducible: Sometimes

Steps to Reproduce:
1. "Fireshot" plugin installed and in midst of taking screenshots and editing them
2. [there are other situations that also produce the same error message, but I didn't document them]
3.
Actual Results:  
as per "Details" above

Expected Results:  
as per "Details" above
The warning is generated by the JS Engine, right ?
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Other Branch
No, it's actually generated by our DOM code.  And their response makes no sense.  If the warning comes up, that means that the script that is actually executing when it comes up is in fact rfhelper.js.
Assignee: general → nobody
Component: JavaScript Engine → DOM
QA Contact: general → general

Comment 3

8 years ago
I have the same problem that Jim above is having except when I updated firefox from 3.6.3 to the current updated 3.6.4 now it is worse
(Reporter)

Comment 4

8 years ago
(In reply to comment #2)
> No, it's actually generated by our DOM code.  And their response makes no
> sense.  If the warning comes up, that means that the script that is actually
> executing when it comes up is in fact rfhelper.js.

So Boris...I'm far from being a coder at MIT, but I love FF AND Roboform and don't want to abandon either...but I'm still getting the same error message two months and a couple FF updates later. Anything specific I can do to help the process? Are you aware of any communication between Roboform and FF engineers?
There has been some in the past...  Not necessarily always productive, though.

Chris, do we have current contacts with them?
Not that I know of.  Justin?
(In reply to comment #6)
> Not that I know of.  Justin?

I don't have any individual contacts there. Their AMO-hosted add-ons publicly list their email as ask@siber.com, so could try there.
I have a few direct contacts. I'll let them know about this bug.
(Reporter)

Comment 9

8 years ago
(In reply to comment #8)
> I have a few direct contacts. I'll let them know about this bug.

Muchisimas gracias Sr. !

Comment 10

8 years ago
We will try to fix this error ASAP.

It sure does not happen on clean Firefox installs,
probably is an interaction with other addons.

Or can be this leak that we fixed in Adapter 6.10.0.
Leak would make it unresponsibe after it has leaked enough.

Does it happen with Adapter 6.10.0?
(Reporter)

Comment 11

8 years ago
(In reply to comment #10)
> We will try to fix this error ASAP.
> 
> It sure does not happen on clean Firefox installs,
> probably is an interaction with other addons.
> 
> Or can be this leak that we fixed in Adapter 6.10.0.
> Leak would make it unresponsibe after it has leaked enough.
> 
> Does it happen with Adapter 6.10.0?

Yes, still happening with Adapter 6.10.0 and FF 3.6.10

Comment 12

8 years ago
this will be fixed in the next release of RF.

this is details:

bug - sometimes Firefox shows 'warning: unresponsive script' message box which points to our rfhelper.js script. This is because our script may execute for too long. Actually our script does not do much but it calls Firefox functions that may take long time to return.  There is a setting in Firefox named dom.max_script_run_time which specifies script execution timeout.

Fix: set dom.max_script_run_time value to 0 (to disable timeout) at the beginning of the FillDocument function and restore it to original value at the end.
Added appropriate functions to adapter to set/get value of the script timeout setting.
Is it possible to run this code on a different thread, perhaps using a Worker?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

8 years ago
(In reply to comment #12)
> this will be fixed in the next release of RF.

bug invalid then?
Summary: Warning: Unresponsive Script: [Script: file:///I:/Program%20Files/Siber%20Systems/AI%20RoboForm/Firefox/components/rfhelper.js:129] → Warning: Unresponsive Script: [Script: file:///I:/Program%20Files/Siber%20Systems/AI%20RoboForm/Firefox/components/rfhelper.js:129] roboform
Can somebody confirm the bug is fixed?

Comment 16

8 years ago
this one was fixed some time ago, both in ver 6 and 7.

we are now switching to ver 7 where it is defnitely fixed.
Let's give some time for one of the reporters to try to reproduce. If there's no response we can close the bug as WFM.

Comment 18

3 years ago
closing WFM per previous comments
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.