[Win-Cd] "REFTEST TEST-UNEXPECTED-FAIL | crashtests/489462-1.html | assertion count 1 is more than expected 0 assertions"

RESOLVED DUPLICATE of bug 573026

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 573026
8 years ago
8 years ago

People

(Reporter: Callek, Unassigned)

Tracking

({assertion})

Trunk
x86
Windows XP
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
This has to be an odd place for this assertion, but nonetheless it happens.



REFTEST TEST-START | file:///e:/builds/slave/comm-central-trunk-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/489462-1.html
++DOMWINDOW == 20 (1371B1D0) [serial = 2304] [outer = 09E2E658]
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
Error opening default audio device.
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
REFTEST TEST-PASS | file:///e:/builds/slave/comm-central-trunk-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/489462-1.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
++DOMWINDOW == 21 (13B21580) [serial = 2305] [outer = 09E2E658]
###!!! ASSERTION: Should have positive frame time: 'videoData->mTime >= mStartTime', file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/media/nsBuiltinDecoderStateMachine.cpp, line 1115
gklayout!nsBuiltinDecoderStateMachine::Run+0x00000000000003E0 (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\content\media\nsbuiltindecoderstatemachine.cpp, line 807)
xpcom_core!nsThread::ProcessNextEvent+0x00000000000001FA (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\xpcom\threads\nsthread.cpp, line 547)
xpcom_core!NS_ProcessNextEvent_P+0x0000000000000053 (e:\builds\slave\comm-central-trunk-win32-debug\build\objdir\mozilla\xpcom\build\nsthreadutils.cpp, line 250)
xpcom_core!nsThread::ThreadFunc+0x00000000000000CE (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\xpcom\threads\nsthread.cpp, line 263)
nspr4!_PR_NativeRunThread+0x00000000000000DB (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\nsprpub\pr\src\threads\combined\pruthr.c, line 426)
nspr4!pr_root+0x0000000000000019 (e:\builds\slave\comm-central-trunk-win32-debug\build\mozilla\nsprpub\pr\src\md\windows\w95thred.c, line 122)
MSVCR80D!beginthreadex+0x0000000000000221
MSVCR80D!beginthreadex+0x00000000000001C7
kernel32!GetModuleHandleA+0x00000000000000DF
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2719
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/slave/comm-central-trunk-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/489462-1.html | assertion count 1 is more than expected 0 assertions
(Reporter)

Updated

8 years ago
Summary: [SeaMonkey] [Win-Cd] "REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/slave/comm-central-trunk-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/489462-1.html | assertion count 1 is more than expected 0 assertions" → [SeaMonkey] [Win-Cd] "REFTEST TEST-UNEXPECTED-FAIL | crashtests/489462-1.html | assertion count 1 is more than expected 0 assertions"
Comment hidden (Treeherder Robot)
(Reporter)

Comment 2

8 years ago
Same underlying issue as Bug 570142 I suspect. and this is not perma on sm anymore, also it seems that romaxa's push on try indicates its not *only* a SM problem.
Summary: [SeaMonkey] [Win-Cd] "REFTEST TEST-UNEXPECTED-FAIL | crashtests/489462-1.html | assertion count 1 is more than expected 0 assertions" → [Win-Cd] "REFTEST TEST-UNEXPECTED-FAIL | crashtests/489462-1.html | assertion count 1 is more than expected 0 assertions"
Whiteboard: [sm-perma][orange] → [orange]

Updated

8 years ago
Blocks: 438871

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573026

Updated

8 years ago
No longer depends on: 573026
No longer blocks: 438871
No longer depends on: 570142
Keywords: assertion
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.