qute theme: tabbar background shadow image not shown

RESOLVED FIXED in Thunderbird 6.0

Status

Thunderbird
Theme
--
trivial
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: gekacheka, Assigned: gekacheka)

Tracking

({polish})

unspecified
Thunderbird 6.0
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2pre Thunderbird/3.1

In the default windows theme (qute), the tabbar background image is not shown.


Reproducible: Always

Actual Results:  
The tabbar has no shadow (faded gradient image), unlike Firefox.

Expected Results:  
The tabbar has shadow (faded gradient image), like Firefox.
(Assignee)

Comment 1

7 years ago
Created attachment 452561 [details]
actual image showing tabbar background without shadow
(Assignee)

Comment 2

7 years ago
Created attachment 452563 [details]
expected image showing tabbar background shadow like Firefox
(Assignee)

Comment 3

7 years ago
Created attachment 452565 [details] [diff] [review]
patch v1: fix thunderbird tabbar image url in qute theme css

Url was missing '/icons' subdir.
Result is as shown in expected image.
Assignee: nobody → gekacheka
Attachment #452565 - Flags: review?(bugzilla)
(Assignee)

Updated

7 years ago
Keywords: polish
Comment on attachment 452565 [details] [diff] [review]
patch v1: fix thunderbird tabbar image url in qute theme css

Andreas, can you take a look at this please?
Attachment #452565 - Flags: review?(bugzilla) → review?(nisses.mail)
Wow, sorry for the review delay. A week on vacation + odd build issues (bug 576074) got in the way. While this looks good on XP, it makes the appearance under Aero (Vista/7) worse and different from what Firefox does. ui-r+ if you make the needed changes for Aero however.
Created attachment 455471 [details]
this is how the tab bar in firefox looks under Aero
Comment on attachment 452565 [details] [diff] [review]
patch v1: fix thunderbird tabbar image url in qute theme css

so setting minus for now
Attachment #452565 - Flags: review?(nisses.mail) → review-
(Assignee)

Comment 8

7 years ago
Sorry, I have no access to aero, so cannot implement the aero part.

Looks like firefox changed from 1.9.2 to trunk; trunk may not be final.
(So may need to decide which version of firefox to try to match.  For now probably 1.9.2 since trunk may not be final for many months.)

In 1.9.2, .tabbrowser-tabs background in browser.css has css like this:
http://mxr.mozilla.org/mozilla1.9.2/source/browser/themes/winstripe/browser/browser.css#1035
But I can't tell from looking at the code (without DOM inspector) what makes gradient different in aero.  (browser-aero.css does not override background.)

In current trunk, TabsToolbar background in browser.css has css like this:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/browser.css#1091
(Again, not overridden in browser-aero.css.)

de-assigning myself.
Assignee: gekacheka → nobody
Mass move to the new theme component.
Component: Toolbars and Tabs → Theme
QA Contact: toolbars-tabs → theme
Comment on attachment 452565 [details] [diff] [review]
patch v1: fix thunderbird tabbar image url in qute theme css

Now we have a separate tabmail.css for Vista/Win7 and this patch only affects the XP theme.

r? again
Attachment #452565 - Flags: review- → review?(nisses.mail)
Comment on attachment 452565 [details] [diff] [review]
patch v1: fix thunderbird tabbar image url in qute theme css

I haven't tried this in action (don't have access to a XP system), but it looks for the image in the right place for the image now.
Could someone post a XP screenshot, just so we're on the safe side that it won't need the !important string.

r+=me as long as that works.
Attachment #452565 - Flags: review?(nisses.mail) → review+
Created attachment 533609 [details]
Tabbar background with patch
I assigned this Bug to gekacheka@yahoo.com because it's his patch.
Assignee: nobody → gekacheka
Status: NEW → ASSIGNED
Keywords: checkin-needed
(In reply to comment #12)
> Created attachment 533609 [details]
> Tabbar background with patch

Cool. Looks great!
http://hg.mozilla.org/comm-central/rev/3115956e3f0f
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.4
You need to log in before you can comment on or make changes to this bug.