uptime does not sort numerically

VERIFIED FIXED in 1.7.6

Status

Socorro
General
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: wsmwk, Assigned: ryansnyder)

Tracking

Trunk
1.7.6
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
https://crash-stats.mozilla.com/report/list?version=Thunderbird%3A3.0.5&build_id=&query_search=signature&query_type=exact&query=&date=2010-06-20%2008%3A00%3A00&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=&signature=nsQueryInterface%3A%3Aoperator%28%29%28nsID%20const%26%2C%20void**%29&missing_sig=&page=1

click uptime 
get ordering like
1
10
116
14
17725
189
2
2
22586
(Reporter)

Comment 1

8 years ago
p.s. I could swear this was working fine a few days ago
From the closed bugs (https://bugzilla.mozilla.org/buglist.cgi?chfieldto=Now&query_format=advanced&chfieldfrom=2010-04-01&short_desc=sort&bug_status=RESOLVED&bug_status=VERIFIED&short_desc_type=allwordssubstr&component=Socorro&product=Webtools), it looks like Ryan fixed most of the existing sort bugs for 1.7 (but bug 564088 missed the cut, as apparently did this column).
Thanks guys, I'll take a look.  I can reproduce the error on stage, but haven't been able to reproduce it in my sandbox yet.  I'll keep poking at it.
Assignee: nobody → ryan
Status: NEW → ASSIGNED
Target Milestone: --- → 1.8
Created attachment 452802 [details] [diff] [review]
Patch 1 for 573378

1. Forcing column 9 Uptime to sort numerically
2. Fixed auto-sort, which was auto-sorting on the Uptime field instead of the Comments field.  The addition of the Hang column shifted the Comments field 1 column to the right (column 9 instead of column 10).
3. Fixed nav problems in sandboxes from */report* pages
Attachment #452802 - Flags: review?(ozten.bugs)
Attachment #452802 - Flags: feedback?
Attachment #452802 - Flags: review?(laura)

Updated

8 years ago
Attachment #452802 - Flags: review?(laura) → review+
Thanks Laura.  Committing.  Wayne and/or Smokey, could you please test this fix on stage?  The changes should appear there by 2:15pm PST.  Thanks!

==

Sending        webapp-php/application/controllers/report.php
Sending        webapp-php/js/socorro/report_list.js
Transmitting file data ..
Committed revision 2161.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
looks good at http://crash-stats.stage.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=hang%20|%20mozilla%3A%3Aipc%3A%3ARPCChannel%3A%3ACall%28IPC%3A%3AMessage*%2C%20IPC%3A%3AMessage*%29&version=Firefox%3A3.6.4
Attachment #452802 - Flags: review+
Attachment #452802 - Flags: feedback?

Updated

8 years ago
Attachment #452802 - Flags: review?(ozten.bugs)
Verified FIXED; sorting and pagination don't play nicely together (the sort option doesn't persist across pages), but that's a separate bug.
Status: RESOLVED → VERIFIED

Comment 8

7 years ago
Verified on prod after 1.8 release.
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> Verified on prod after 1.8 release.

I agree. Thanks!
Merge to 1.7.6
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Target Milestone: 1.8 → 1.7.6
Looks like this was fixed in 1.7.5.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
Oy, wrong bug ticket. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Committing fix from 1.8.

Sending        webapp-php/js/socorro/report_list.js
Transmitting file data .
Committed revision 2714.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Verified FIXED on https://crash-stats.stage.mozilla.com/report/list?version=Firefox%3A4.0b6&build_id=&query_search=signature&query_type=exact&query=&date=&range_value=2&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=&signature=js_fun_apply%28JSContext*%2C%20unsigned%20int%2C%20js%3A%3AValue*%29&missing_sig=&admin=&page=1.
Status: RESOLVED → VERIFIED
Created attachment 491265 [details]
Post-fix screenshot
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.