Last Comment Bug 573384 - rights infobar not displayed any more
: rights infobar not displayed any more
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Startup & Profiles (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1a2
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on: 508039 547406
Blocks: 574645 SMPlacesBMarks
  Show dependency treegraph
 
Reported: 2010-06-20 13:09 PDT by Robert Kaiser
Modified: 2010-06-25 06:09 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
b1+


Attachments
Back out incorrect changes (1.64 KB, patch)
2010-06-20 15:33 PDT, neil@parkwaycc.co.uk
kairo: review+
Details | Diff | Splinter Review

Description Robert Kaiser 2010-06-20 13:09:04 PDT
As I noted in bug 508039 comment #38, bug 558664 removed the subject parameter on the observer notification for the sessionstore-windows-restored topic, and so the infobar for "Know Your Rights" isn't being displayed any more.

I found this because places bookmarks also want to display another notification on the same event if the DB locked.
Comment 1 Robert Kaiser 2010-06-20 13:21:40 PDT
Ouch, the bug that caused the problem is bug 558644, actually.

IMHO the solutions here is one of:
1) Making our way from bug 508039 work again AND port it to Firefox as well so we don't re-do the bug 558644 mistake, or
2) Getting the window the Firefox way and leave the observer notification as it is.
Comment 2 neil@parkwaycc.co.uk 2010-06-20 15:29:13 PDT
Actually it was bug 547406 but yes I completely overlooked it :-(
Comment 3 neil@parkwaycc.co.uk 2010-06-20 15:33:16 PDT
Created attachment 452610 [details] [diff] [review]
Back out incorrect changes
Comment 4 Robert Kaiser 2010-06-20 15:45:26 PDT
Oh, in this case, we really should port this to Firefox as well, both to improve their code and to not port over the error again.

Are you willing to file a bug, possibly even a patch?
Comment 5 neil@parkwaycc.co.uk 2010-06-20 15:55:36 PDT
Pushed changeset de79d19f1f17 to comm-central.
Comment 6 Tony Mechelynck [:tonymec] 2010-06-20 17:28:49 PDT
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a6pre) Gecko/20100619 SeaMonkey/2.1a2pre
Build ID:   20100620161917

I see the infobar in a new profile. I don't expect it to work differently on W32, Mac, or L64 than it does on L32. => VERIFIED. (If someone does not see the infobar in a fresh profile in a SeaMonkey 2.1a2pre built later than comment #5, feel free to REOPEN with details of where and how.)

The fact that, in the default theme, it is the same color as the chrome makes it easy to miss, but if it is wanted to change that it would of course be a different bug.

(I wonder why the user-agent has stopped tracking the build date but that is yet another bug if desired. Maybe intentional against fingerprinting but might make bug-tracking and finding regression ranges harder.)
Comment 7 Robert Kaiser 2010-06-25 06:09:36 PDT
I filed bug 574645 on doing the same trick of passing the window in Firefox code.

Note You need to log in before you can comment on or make changes to this bug.