Closed Bug 573390 Opened 14 years ago Closed 6 years ago

(Default) Character Encoding strings have been switched around

Categories

(SeaMonkey :: Preferences, defect)

SeaMonkey 2.0 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 895751

People

(Reporter: Tonnes, Unassigned)

Details

Attachments

(1 file)

Attached patch The fixSplinter Review
Although most locales appear to have ‘caught’ this tiny error in their locales (or just not implemented the erroneous change), the strings for ‘Character Encoding’ and ‘Default Character Encoding’ have been switched around in en-US. This was likely introduced by changeset 5048efa447ab, dated 2008-09-16. I guess the entities are allright and do not need to be changed, for obvious reasons.
Attachment #452603 - Attachment is patch: true
Attachment #452603 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 452603 [details] [diff] [review]
The fix

Setting review? flag to IanN.
Will need sr? later as this affects the UI.
Attachment #452603 - Flags: review?(iann_bugzilla)
(In reply to comment #0)
> Created an attachment (id=452603) [details]
> The fix
> 
> Although most locales appear to have ‘caught’ this tiny error in their locales
> (or just not implemented the erroneous change), the strings for ‘Character
> Encoding’ and ‘Default Character Encoding’ have been switched around in en-US.
> This was likely introduced by changeset 5048efa447ab, dated 2008-09-16. I guess
> the entities are allright and do not need to be changed, for obvious reasons.

This was actually deliberate to sort out an issue with the width under linux, see https://bugzilla.mozilla.org/show_bug.cgi?id=444411#c39 for details.
Not sure how it appears in other languages on linux.
Comment on attachment 452603 [details] [diff] [review]
The fix

As this will cause UI problems, need a different solution to this.
Attachment #452603 - Flags: review?(iann_bugzilla) → review-
Ian, could you elaborate on the UI problems (as this has never caused any for our locale, nor does it appear to do so for en-US locally)?
Seems to have become an obsolete issue since bug 895751?
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: