Selected components don't appear in the "Custom" path of a customized installer

VERIFIED FIXED in M20

Status

P1
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: robinf, Assigned: vparthas)

Tracking

other
x86
Windows 95

Details

(Reporter)

Description

18 years ago
Steps to reproduce:

1. On last screen of CCK wizard, select some components to install and deselect 
others.
2. Create the custom installer.
3. Launch the custom installer.
4. Choose "Custom" path.
5. The only component that appears listed is Navigator (selected and dimmed). 
The other components I chose in the wizard don't appear.

I'm not able to verify if these components actually get installed (even though 
they're not listed) since I don't have a clean machine. Brent to do further 
testing.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

18 years ago
I guess this was a build issue.
Marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
re-opening....

Latest CCK build dated: 2000-11-14-14
The French, Japanese, and German language paks are not included in the 
customized builds if selected through the CCKTool's Select Components list
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

18 years ago
Varada asked me to test this, so I used the lastest CCK build from 
ftp://sweetlou/products/client/cck/new/win/5.0/domestic/release/Installer/ns/200
0-11-14-14/

and installed it on my Win95 machine. Here's what I did:

On the last page of the tool, I selected Nav, Mail, IM, Spell Checker, 
Macromedia Flash Player, RealPlayer8, and the 4 language packs.

I then created a custom build and went down the "Custom" installation path. The 
only components listed were: Nav, Mail, IM, and Spell Checker. I don't have a 
clean machine, so I can't verify if the other components get installed even if 
they're not listed. In any case, this bug is not yet fixed.

Comment 4

18 years ago
Marking M20, Major, P1
Severity: normal → major
Priority: P3 → P1
Target Milestone: --- → M20

Comment 5

18 years ago
*** Bug 60816 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

18 years ago
Brent - Are missing components installed even if they're not listed? I'll add 
this to the release notes. Thanks.

Comment 7

18 years ago
The French, German, and Japanese language paks are not getting included 
in customized builds even if the end-user selects them in the CCKTool. (bug# 
60816)

The French, German, and Japanese language pak .xpi files do exist within the 
CCKTool\NSCPxpi\ directory.
(Reporter)

Comment 8

18 years ago
Brent: As a workaround, can the language pack xpi files be copied by hand into a 
custom build? If so, where should the user copy them to? Thanks.

Comment 9

18 years ago
To further clarify... 

If user chooses to select all the available language paks on the "Create the 
Installer" page and proceeds to select the "Build Installer" button, the CCKTool 
doesn't include the langende.xpi, langenfr.xpi, and langenjp.xpi files that 
exist in the NSCPxpi\ directory.
(Assignee)

Comment 10

18 years ago
Marking Fixed.
This problem was caused by the "ADDITIONAL" screen components not being in the
loop for the "if" conditions.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Marking this Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.