Won't check for updates if running as Standard User

RESOLVED DUPLICATE of bug 318855

Status

defect
RESOLVED DUPLICATE of bug 318855
9 years ago
9 years ago

People

(Reporter: tjazar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

Thunderbird will not notify me of any updates if I run the program as a Standard User.  In fact, the "Check for Updates" option is grayed-out in the "Help" menu.  I have to manually check the Thunderbird home page and cross reference the current version number with my "About Thunderbird" window to find out if I am running the latest version.

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird for Standard User.
2. Run as Standard User.
3. Click "Help" menu, "Check for Updates" should not be available to click.
Actual Results:  
"Check for Updates" not available to click.

Expected Results:  
"Check for Updates" should be available to notify user of any updates to Thunderbird.  If user does not have admin privileges, Thunderbird should wait until user supplies privileges to update program.

Running as Administrator allows the user to update, but this is not a viable solution, as if defeats the purpose of the Standard User account.  Thunderbird should at least notify a Standard User of an update (unless it is specifically told not to).
Your issue is Invalid, because the privileges are designed for this... if you disagree, please read microsoft note at

http://windows.microsoft.com/en-us/windows7/Why-use-a-standard-user-account-instead-of-an-administrator-account
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Thunderbird shouldn't need root privileges to check for updates.  I agree that such privileges are necessary by design for actually installing/updating software, but to perform a version check and notify the user seems excessive and potentially unsafe, as it would force the user to run Thunderbird as root just to receive update notices.
Ok I agree with you... and also others.

Set as dupe of bug #318855
Resolution: INVALID → DUPLICATE
Duplicate of bug: 318855
(Reporter)

Comment 4

9 years ago
Thank you for marking duplicate.
You need to log in before you can comment on or make changes to this bug.