Cuddlefish application.ini not found when running cfx testall

RESOLVED WORKSFORME

Status

Add-on SDK
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: WebAudioUser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Jetpack SDK 0.4

Cuddlefish application.ini seems to be missing from .app archive. Navigating to the archive shows it is not present.

Reproducible: Always

Steps to Reproduce:
1. unpack Jetpack SDK
2. run "source bin/activate" from folder 
3. run "cfx testall"
Actual Results:  
Command line dump:

(jetpack-sdk-0.4)Boriss:~/Desktop/jetpack-sdk-0.4 Ben$ cfx testall
Testing cfx...
.......................E.......................
======================================================================
ERROR: test_generate_static_docs_does_not_smoke (cuddlefish.tests.test_server.ServerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/tests/test_server.py", line 12, in test_generate_static_docs_does_not_smoke
    server.generate_static_docs(env_root, tgz_filename=filename)
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/server.py", line 400, in generate_static_docs
    os.path.join(dest_dir, "README.md"))
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/shutil.py", line 52, in copyfile
    fsrc = open(src, 'rb')
IOError: [Errno 2] No such file or directory: '/Users/Ben/Desktop/jetpack-sdk-0.4/packages/my-first-package/README.md'

----------------------------------------------------------------------
Ran 47 tests in 3.027s

FAILED (errors=1)
Testing reading-data...
/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/__init__.py:563: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  if e.message.startswith(MOZRUNNER_BIN_NOT_FOUND):
Traceback (most recent call last):
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/bin/cfx", line 6, in <module>
    cuddlefish.run()
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/__init__.py", line 312, in run
    test_all(env_root, defaults=options.__dict__)
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/__init__.py", line 190, in test_all
    test_all_examples(env_root, defaults)
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/__init__.py", line 221, in test_all_examples
    env_root=env_root)
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/__init__.py", line 561, in run
    logfile=options.logfile)
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/runner.py", line 289, in run_app
    kp_kwargs=popen_kwargs)
  File "/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/runner.py", line 162, in __init__
    raise ValueError("file does not exist: '%s'" % self.__app_ini)
ValueError: file does not exist: '/Users/Ben/Desktop/jetpack-sdk-0.4/python-lib/cuddlefish/Test App.app/Contents/Resources/application.ini'

Expected Results:  
Tests all pass

I'm running Python 2.6.4 on OSX 10.4.11 (Tiger)
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Hmm, I haven't been able to reproduce this.  Out of curiosity, what happens when you run |cfx testall| with the 0.5rc3 build (the latest release candidate build, which is likely to become the 0.5 final release build)?

  https://ftp.mozilla.org/pub/mozilla.org/labs/jetpack/jetpack-sdk-0.5rc3.tar.gz
(Reporter)

Comment 2

8 years ago
Seems to work, how odd:

cmd line dump:

(jetpack-sdk-0.5)Boriss:~/Desktop/jetpack-sdk-0.5 Ben$ cfx testall
Testing cfx...
.................................................
----------------------------------------------------------------------
Ran 49 tests in 4.594s

OK
Testing reading-data...
.info: My ID is 6724fc1b-3ec4-40e2-8583-8061088b3185
..
Malloc bytes allocated (in use by application): 7099711
Malloc bytes mapped (not necessarily committed): 31539521
Malloc bytes committed (r/w) in default zone: 7105632
Malloc bytes allocated (in use) in default zone: 14422016
Tracked memory objects in testing sandbox: 2

3 of 3 tests passed.
OK
Total time: 6.062365 seconds
Program terminated successfully.
Testing all available packages: nsjetpack, test-harness, jetpack-core, development-mode.
.................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................2010-06-22 18:50:19.702 firefox-bin[6141] CFLog (0): CFMessagePort: bootstrap_register(): failed 1103 (0x44f), port = 0x6103, name = 'org.mozilla.firefox.ServiceProvider'
See /usr/include/servers/bootstrap_defs.h for the error codes.
2010-06-22 18:50:19.703 firefox-bin[6141] CFLog (99): CFMessagePortCreateLocal(): failed to name Mach port (org.mozilla.firefox.ServiceProvider)
...........debug: Updating storage!
..debug: Bad JSON!
.........................................................................................................................................................................................................................................................................................................
object count is 9486 in 80 modules (19231 across entire JS runtime)

Malloc bytes allocated (in use by application): 18198335
Malloc bytes mapped (not necessarily committed): 76685633
Malloc bytes committed (r/w) in default zone: 18200160
Malloc bytes allocated (in use) in default zone: 59568128
Tracked memory objects in testing sandbox: 2

1255 of 1255 tests passed.
OK
Total time: 9.010003 seconds
Program terminated successfully.
All tests were successful. Ship it!
Indeed, that's strange.  But I guess we fixed whatever the problem was between these two releases!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.