Status

RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: kodella, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18

I just installed version 2.0, in a different directory from version 1.1.18, and it will not open. I had hoped to delete version 1.1.18, but it looks like I won't be. Help!

Reproducible: Always

Comment 1

8 years ago
Have you close Quick Launch from version 1.1.18?
Just to be clear; what happens when you try to open it.

Did it install "correctly" (how do you know).

Did it [offer to] create/migrate your 1.1.x profile?

Did you have any windows from SeaMonkey 1.1.x open, did you have the Quick Launch from SM 1.1.x open....

Basically, much more info is needed to try and diagnose this issue.
(Reporter)

Comment 3

8 years ago
Nothing, Justin. Just like I said. Nothing happens. Nix. Nada. Zilch. However, I did have the Quick Launch open from 1.1.18 open. I will close it and re-install and see what happens.

I would say it did install correctly. I know this the same way I know anything installs correctly. There were no error messages or unusual delays in the installation process.

If it does work, I can tell you that the migration process appears to be sufficiently complicated that I may stop there and be content with the old version.

Thanks for your interest.
(In reply to comment #3)
> Nothing, Justin. Just like I said. Nothing happens. Nix. Nada. Zilch. However,
> I did have the Quick Launch open from 1.1.18 open. I will close it and
> re-install and see what happens.

Having the quick launch open tells your system that SeaMonkey 1.1.x is running and it will *refuse* to launch the new version. Sorry, but SeaMonkey is SeaMonkey is SeaMonkey.

Close that then re-run the program. Even better if you just uninstall 1.1.x (you won't loose your profile by doing so) and install 2.0 in its default location and just run it.

This way you'll know that 1.1.x is not open to begin with.
(Reporter)

Comment 5

8 years ago
Right. I understand two copies cannot run at the same time. You have presented what is probably the best solution: uninstall 1.x first, while retaining profile data.

But, I still am reluctant to take on a steep learning curve in the migration process. Thanks for the advice!
-no-remote

Allows multiple copies of application to be open at a time. (Not in SeaMonkey1.x, which only supports MOZ_NO_REMOTE=1).

C:\Path\To\SM2x\seamonkey.exe -no-remote

--
This will allow you to run SM 1.x and SM 2.x side by site.

I must note that this will work with 2.0 and 2.1 but only if you specify a different profile path using it's command line. This works between 1.x and 2.x without any other command line arguments because 1.x and 2.x store their profiles in different directories.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Whiteboard: [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.