mozilla control crashing in VB6

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: chris, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

This has been a problem for a while and never seems to get fixed. I was using XUL version 1.8.1.3 in VB6 and it worked fine. But now some sites are crashing it and i need to update. When I try the 1.9 versions VB6 comes up "invalid URL" lots of times, even before the form has loaded, then VB crashes. I had these issues months ago but using 1.8 always worked fine. 1.9 just seems to crash a lot and I really have no idea why. If I try to stop the app running with break points then stop it, VB crashes also with V1.9. Just cant get it to do anything. Any help  with this ? 

Reproducible: Always

Steps to Reproduce:
1.copy V1.9 control onto a form
2. run the app then close it, 
3. VB crashes.

Comment 1

8 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_windbg
(Reporter)

Comment 2

8 years ago
The problem is with debugging the crash, is that the control does not load correctly in the first place either so that needs to be looked into first.  When the control loads it just comes up "INVALID URL" then it comes up things like "www.???????????????????????????????????5??.com" a few times. this is even before the form has loaded and its nothing it my code which is causing it as its not got that far yet. 

Seems to be some bug relating to the loading of the control, maybe its trying to load a url which isn't there, but that would be internal to the control itself.  Theres nothing i can do as its some loading issue within VB6 so nothing i do will have any effect. 

V1.8 was a bit iffy that it would only run once, then i had to close VB and reload the project for it to work. I tracked it down to mozilla.oca which is a VB cache file, I have to delete that in order for the mozilla control to work at all. But once VB creates it, the control stops working. 

So theres a lot of VB issues here but while V1.8 was partly working. V1.9 just fails to work at all :-(

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 3

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
(Reporter)

Comment 4

7 years ago
this thread is a year old,... i just stopped using firefox in my apps.

Comment 5

7 years ago
Closing bug as Incomplete - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.