Speed up Page Info > Media

RESOLVED FIXED in Firefox 3.7a5

Status

()

Firefox
Page Info Window
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: tmyoung, Assigned: tmyoung)

Tracking

({perf})

Trunk
Firefox 3.7a5
Points:
---

Firefox Tracking Flags

(status1.9.2 .9-fixed)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 452889 [details] [diff] [review]
Patch v. 1.0

From the discussion in Bug 515549, let's do two--possibly three--things to speed up Page Info's media.

1. Lower the timeouts to the minimum of 10ms
2. Increase the number of elements processed at once
3. (Optional) Replace timeouts with postMessage as described here: http://dbaron.org/log/20100309-faster-timeouts

This patch does the first two, and it can do the third if needed.

http://commons.wikimedia.org/wiki/Category:Crater_Lake is a decent example of speed testing if you run "View Image Info" on the last image.
Attachment #452889 - Flags: review?(db48x)
We need longer testcases. Page Info (trunk) has finished with every page I've tried so far before I could even click on the Media tab.
(Assignee)

Comment 2

8 years ago
Created attachment 452905 [details] [diff] [review]
Patch v. 1.1

Setting to 500 elements per loop.
Attachment #452889 - Attachment is obsolete: true
Attachment #452905 - Flags: review?(db48x)
Attachment #452889 - Flags: review?(db48x)
Comment on attachment 452905 [details] [diff] [review]
Patch v. 1.1

r=db48x
Attachment #452905 - Flags: review?(db48x) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=a32ea115521e
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Target Milestone: --- → Firefox 3.7a6
Version: unspecified → Trunk
(Assignee)

Updated

8 years ago
Target Milestone: Firefox 3.7a6 → Firefox 3.7a5
(Assignee)

Comment 5

8 years ago
Comment on attachment 452905 [details] [diff] [review]
Patch v. 1.1

From bug 579717 this appears to fix hangs and performance problems on Mac OSX--more than it does on Windows.  I propose that we port the change to 1.9.2.

I will quickly make sure that the patch doesn't conflict with anything, but it shouldn't touch code that's 2.0-branch specific.
Attachment #452905 - Flags: approval1.9.2.8?
(Assignee)

Updated

8 years ago
Keywords: perf
(Assignee)

Updated

8 years ago
Duplicate of this bug: 579717
Comment on attachment 452905 [details] [diff] [review]
Patch v. 1.1

Please renominate for branch landing once you've confirmed that it compiles on that branch, preferably with tryserver builds and test runs! :)
Attachment #452905 - Flags: approval1.9.2.8? → approval1.9.2.8-
(Assignee)

Comment 8

8 years ago
Comment on attachment 452905 [details] [diff] [review]
Patch v. 1.1

This works on 1.9.2 like it does on Trunk.  The patch doesn't need any branch-specific changes.
Attachment #452905 - Flags: approval1.9.2.8- → approval1.9.2.8?
Comment on attachment 452905 [details] [diff] [review]
Patch v. 1.1

a=beltzner for mozilla-1.9.2, simple safe perf improvement for non-critical code path
Attachment #452905 - Flags: approval1.9.2.9? → approval1.9.2.9+
(Assignee)

Comment 10

8 years ago
This needs check-in on the 1.9.2 branch.
Keywords: checkin-needed

Comment 11

8 years ago
Can the same type of fix be applied for bug 513092?
(Assignee)

Comment 12

8 years ago
(In reply to comment #11)
> Can the same type of fix be applied for bug 513092?

It's all a question of the code that populates that list.  Either the code is using timeouts or it's waiting on something else.  If it is the former, then yes, this same philosophy can be applied, but if it is the latter, I'm not sure.

Since I don't know that code or what would be causing it, I couldn't say, but someone like Dao or Gavin would have better answers.
(Assignee)

Updated

8 years ago
Whiteboard: [c-n 1.9.2]
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/3b265279e11b
status1.9.2: --- → .9-fixed
Keywords: checkin-needed
Whiteboard: [c-n 1.9.2]
You need to log in before you can comment on or make changes to this bug.