Closed Bug 573612 Opened 10 years ago Closed 10 years ago

Component overrides do not work in omnijar

Categories

(Core :: General, defect)

All
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 2.0a1+ ---

People

(Reporter: mbrubeck, Assigned: mwu)

References

Details

Omnijar does not register components in a guaranteed order based on components.list, so components cannot reliably override contractIDs of other components.  This causes Fennec components like PromptService not to work on Android (originally reported as bug 573130).
I'm going to wait for bsmedberg's rewrite of component loading before tackling this properly, assuming it'll even be necessary after that. In the meantime I'm going to do some stupid tricks with our packaging to make things work as expected.
tracking-fennec: --- → 2.0+
Matt/Mwu, is this WFM/INVALID/or NEW as of now (since ben's component loading changes have landed).
This is still reproducible with the new component registration code.
tracking-fennec: 2.0+ → 2.0a1+
bsmedberg, i heard that this bug will be fixed by your work on combined-manifests.
Very likely. That's hung up on getting Talos fixed, but I think it should land next week.
Fixed by bug 579178 AFAICT.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.