AddonInstall.sourceURL should be accessible as a nsIURI

VERIFIED DUPLICATE of bug 575463

Status

()

VERIFIED DUPLICATE of bug 575463
8 years ago
8 years ago

People

(Reporter: Unfocused, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [AddonsRewrite])

AddonInstall.sourceURL is currently exposed as a string - but its often used as a nsIURI. Basically, the same reasoning behind bug 563262.
Means we would have to change the API? A good reason to do it as early as possible? Looks like to be an easy patch.
blocking2.0: --- → ?
Version: unspecified → Trunk
Again not a blocker I think. Would take a patch to convert to sourceURI though. That could likely land after first beta since this API is probably far less used by add-ons.
blocking2.0: ? → -

Comment 3

8 years ago
This bug was forgot and this was done in bug 575463.
No longer blocks: 461973
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575463
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.