Messages "passively" displayed should be marked as read (at least as option)

RESOLVED INVALID

Status

Penelope
General
P3
normal
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: John Rose, Assigned: Matt Dudziak)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.19) Gecko/2010040116 Ubuntu/9.04 (jaunty) Firefox/3.0.19 ( .NET CLR 3.5.30729)
Build Identifier: Eudora 8.0b9 

I have selected the Penelope option "Automatically mark messages as read" and "Immediately on display". When I scroll through the messages in a folder and read the content without double clicking the message, the messages are not automatically marked as read. This is inconvenient since to mark as read I either have to double click or go to the mark menu, in either case taking a few seconds, and if there is a lot of unread mail this adds quite a bit of time and effort. I just tested Thunderbird under Windows and find that viewing the messages without selecting them causes them to be marked as read. I suggest that Eudora should work like Thunderbird.

Reproducible: Always



Expected Results:  
I suggest that Eudora should work like Thunderbird, i.e. when one browses thorugh a list of messages without double clicking on them, the messages browsed should be marked as read (at least as an option)
(Reporter)

Comment 1

8 years ago
Sorry, the option "Automatically mark messages as read" is under "Advanced" not "Penelope" which means that it is from Thunderbird, not Eudora. But then I do not understand why my results in Eudora are different from in Thunderbird [Maybe because I am comparing Windows Thunderbird with Linux Eudora]?
(Reporter)

Comment 2

8 years ago
I just checked on Eudora under Windows, same behaviour as under Linux. Thanks and best regards, John
(Assignee)

Comment 3

8 years ago
Confirmed.
When a message is 'actively' selected, like when you use the arrow keys to select the message and preview it, I think it should be marked as read. We would NOT want to mark a message read if it were _passively_ selected, like by filters opening a mailbox and selecting an unread message, or by a message being auto-selected when another message is deleted.

Confirmed that marking read immediately on display is not working. After a delay DOES work.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P3
Hardware: x86 → All
(Reporter)

Comment 4

8 years ago
I tend to agree with Matt's suggestion, although for me previewing a message does not seem to mark it red after a delay of about a minute.

I have gone back an checked in classic Eudora and previewing does not mark as read! So I wondered why this feature did not irritate me for 15 years and now does in Eudora 8. I think that the reason is that when you double click on a message to mark it as read, and then close the message, you don't get back into the same place where you clicked, but rather to the last tab, then you have to remember the folder in which you were to get back to it. The alternative of right clicking and then marking the message as read is less convenient for heavy usage because less automatic. I feel that if the program went back to the folder from which the message was clicked, the marking of read upon passive selection would perhaps not be needed (altough still would be nice as an option).

Comment 5

8 years ago
This is actually working the way it's intended, and as you noted is consistent with Classic Eudora behavior.  I specifically made the immediate mark as read not apply to the preview pane as Classic Eudora doesn't do that.

If you really want immediate mark as read in the preview pane, you can set the pref to a delay of 0.  You may find you don't like that, though, as then if you just arrow through the messages in a mailbox they wind up getting marked as read.

It's very difficult to tell when a user has truly read a message, so what we really need is a mind reading algorithm! :-)


As to the tab focus issue you bring up, a change I noticed Firefox made a while back was that new tabs that get opened by an existing tab get added immediately after that tab rather than at the end.  That would probably be a good behavior to mimic and is really applicable to Thunderbird in general, not just Eudora/Penelope.

One feature you may not be aware of Shift+Space toggles the read status of a message.  Very easy if you mainly use the keyboard to read mail, but not too bad to do with one hand if your other hand is on the mouse.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

8 years ago
Thanks, Jeff, the toggle solves all of my problems (would be nice to have it in the documentation if not there already), best regards, John

Comment 7

8 years ago
The old Eudora had an option to use Ctrl+Arrow to move to the next message while marking the current one as read.
This combination doesn't work anymore in the new Eudora. 
Instead, we can use Shift+Spacebar to toggle the status to read/unread, but it doesn't move to the next message.
Coupled with a short delay to mark the message as read, it is ok, but still not as good as being able to control it in one step.

Is this thread closed (as it is marked RESOLVED  INVALID), or can we still use it to add the Ctrl+arrow feature ?
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)

> 
> Is this thread closed (as it is marked RESOLVED  INVALID), or can we still use
> it to add the Ctrl+arrow feature ?

I'd suggest that you open a new bug for that request, just to be safe.

Matt
(Reporter)

Comment 9

8 years ago
I feel that the addition of so many micro-features without full documentation may become counterproductive if the different features are not more intuitively accessible. If possible I would suggest introducing the Ctrl+arrow feature and at the same time replacing the Shift+space for read toggling by Ctrl+space. This would make the toggling much easier (shift and space require more coordination and possibly two hands) and make the two related functions more similar. Right now Ctrl+space seems to toggle the bottom dispaly panel between the message and a blank panel, hard to see the utility of this function?
You need to log in before you can comment on or make changes to this bug.