Android onscreen keyboard does not reappear when touching already-focused input

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: shollmann, Assigned: jchen)

Tracking

({inputmethod})

Trunk
ARM
Android
inputmethod

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; es-AR; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 FireTorrent/2.0.1
Build Identifier: Mozilla/5.0 (Android;U;Linux armv7l; en-US;rv:1.9.3.a6pre) Gecko/20100622 namoroka/3.7a6pre Fennec/2.0a1pre

When you want to retype the URL the soft keyboard crashes. So you cant retype. They keyboard will appear just for a second.

Reproducible: Always

Steps to Reproduce:
1. Press the URL Bar.
2. Write or not.
3. Push the back button.
4. Press the URL Bar.

Actual Results:  
They keyboard will appear just for a second and then i will disappear.

Expected Results:  
I expect the soft keyboard in order to write the url.

I tried it on Android 2.1 in a Motorola Milestone (Argentina).
Component: General → Linux/Maemo
OS: Other → Linux (embedded)
QA Contact: general → maemo-linux
Hardware: Other → ARM
Component: Linux/Maemo → General
OS: Linux (embedded) → Android
QA Contact: maemo-linux → general
This affects all text fields, not just the urlbar.  Updating summary.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: inputmethod
Summary: When you click more than one time the URL Bar, the Software Keyboard crashs → Android onscreen keyboard does not reappear when touching already-focused input
Duplicate of this bug: 565405
tracking-fennec: --- → 2.0+
Depends on: 576065

Comment 3

8 years ago
It's not working either on HTC Desire Android 2.1 with Fennec 1.

To resolve this issue, I force Fennec to stop in Application Administrator of Android (but it's not really practical.

Updated

8 years ago
tracking-fennec: 2.0+ → 2.0a1+
(Assignee)

Comment 4

8 years ago
Created attachment 458865 [details] [diff] [review]
Quick fix v1

There's a pretty easy fix for this. Whenever a textbox is touched/clicked, nsIWidget::ResetInputState() is called. We can show the keyboard there.

ResetInputState isn't designed for this purpose though and it's called from a bunch of places, but for an easy fix this one's probably the simplest. I didn't see any problems from simple testing.

The patch is Android-only right now.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 580269
Assignee: nobody → jchen
(Assignee)

Comment 6

8 years ago
Fixed by bug 576065
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b2pre) Gecko/20100805 Namoroka/4.0b3pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.