Add-on rating in developer page says "not yet rated" when the add-on has a 4 star rating

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Details

(Whiteboard: [z], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 453102 [details]
screenshot

steps to reproduce:
1.go to https://next.addons.mozilla.org/en-US/firefox/addon/8585/developers#t-author-1284752
2.Notice that "Average rating of their add-ons" has "not yet rated"

observed behavior:

Add-on rating in developer page says "not yet rated" when the add-on they developed-"stephen3000!" has a 4 star rating
This is calculated in a cronjob.
Actually, this add-on doesn't have any reviews.  The review score doesn't get updated due to bug 570617.  I'll get there soon.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Actually, this add-on doesn't have any reviews.  The review score doesn't get
> updated due to bug 570617.  I'll get there soon.

This is not invalid.This is a symptom of bug 570617.I am making this bug a dependent on the other and reopening .

Resolved Invalid is when its clearly user error.If there is a known bug which is causing the behavior of some other component to be different-it is a dependent bug.
Status: RESOLVED → REOPENED
Depends on: 570617
Resolution: INVALID → ---
(Reporter)

Updated

8 years ago
Target Milestone: 5.11.2 → ---
=> FIXED to avoid the wrath of krupa, but I know in my heart this is really => INVALID.  See bug 570617 for the story.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.