Closed Bug 573798 Opened 9 years ago Closed 9 years ago

urlbar loses focus when touched a second time

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Steps to reproduce:
1. Touch the urlbar to focus it.
2. Touch the urlbar again.

Expected results: urlbar is still focused
Actual results: urlbar is not focused

This is a regression from bug 540506. (Oops. Turns out it's a bad idea to blurFocusedElement unconditionally.)
Attachment #453140 - Flags: review?(mark.finkle)
Attachment #453140 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/6c1ce44e8ff8
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110921
Firefox/9.0a1 Fennec/9.0a1
Device: HTC Desire
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.