Wrong placement of text

VERIFIED DUPLICATE of bug 52421

Status

()

P3
normal
VERIFIED DUPLICATE of bug 52421
18 years ago
18 years ago

People

(Reporter: tony.haglof, Assigned: clayton)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    20001018

In the page at http://www.idg.se some text is rendered at the wrong place and 
over some images.

Displays correctly in both Internet Explorer and Netscape 4.x.
Problem exists in both Unix and Windows Mozilla builds and this "bug" have 
existed a long time. (And still exists in build 20001018)


Reproducible: Always
Steps to Reproduce:
1.Go to http://www.idg.se
2.
3.

Actual Results:  Wrong rendering of text.             

Expected Results:  Render the text correctly as IE and NS4.x does.
Page uses layers everywhere...

Comment 2

18 years ago
Created attachment 17661 [details]
Testcase

Updated

18 years ago
Keywords: testcase

Comment 3

18 years ago
Hmm, I *think* that this is how it should be.  The testcase has
position:absolute, but no top defined.  Absolutely possitioned things are
totally out of the normal flow of text, so since no top is defined, it defaults
to 0.  Quote from W3:
http://www.w3.org/TR/REC-CSS2/visuren.html#absolute-positioning

In the absolute positioning model, a box is explicitly offset with respect to
its containing block. It is removed from the normal flow entirely (it has no
impact on later siblings). An absolutely positioned box establishes a new
containing block for normal flow children and positioned descendants. However,
the contents of an absolutely positioned element do not flow around any other
boxes. They may or may not obscure the contents of another box, depending on the
stack levels of the overlapping boxes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
The initial value for 'top' is 'auto' not '0'. An absolutely positioned element
with no explicit 'top' would simply float above where it would have been, and 
all content under it would move up (since, as you correctly said, it is taken
out of flow).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

18 years ago
This is a dup of 52421 really.
Marking as such. 52421 is "evangelist wanted"


*** This bug has been marked as a duplicate of 52421 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verfied duplicate of bug 52421.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.