The default bug view has changed. See this FAQ.

Flashblock does not display play button on Dailymotion videos

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Pierre Rudloff, Assigned: Philip Chee)

Tracking

unspecified
All
Mac OS X

Details

(Whiteboard: [camino-2.0.4], URL)

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (MultiLang) (like Firefox/3.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (MultiLang) (like Firefox/3.0.19)

There is no Flashblock play button on Dailymotion flash videos. A click still launch the video though.

Reproducible: Always

Steps to Reproduce:
1.Activate Flashblock
2.Go to dailymotion.com
3.Click on any video

Actual Results:  
The video block is empty.

Expected Results:  
There should be a play button.
Please contact the developers of Flashblock about the problem: http://flashblock.mozdev.org/

As this big is not about a product, web site or service owned or maintained by Mozilla, I close the bug as Resolved Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Please don't close Camino bugs unless you're a Camino developer.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

7 years ago
The same happens with a recent Minefield nightly.

The button overlay (which is a background-image actually), is killed by this:

body.dm_page_html_video div#top_content_box div.dmpi_video_playerv4 div {
background:none repeat scroll 0 0 transparent !important;
}
http://ak.style.dailymotion.com/css/gen/widget/pack/baseskin-prod.css.v119801261
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

7 years ago
Created attachment 453380 [details]
flashblock.xml: Use !important for our backbround images

> The button overlay (which is a background-image actually), is killed by this:
> 
> body.dm_page_html_video div#top_content_box div.dmpi_video_playerv4 div {
> background:none repeat scroll 0 0 transparent !important;
> }
The attached flashblock.xml sets the !important flag on the background images. Tested on Minefield.
(Assignee)

Comment 5

7 years ago
Not sure who your normal reviewers are. Please set as appropriate.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Comment on attachment 453380 [details]
flashblock.xml: Use !important for our backbround images

philippe, can I have you take this for a spin?  You're probably the Camino person most likely to notice any unintended side effects…
Attachment #453380 - Flags: feedback?(phiw)
And Philip, thanks for the quick fix yet again!
Flags: camino2.0.4?

Comment 8

7 years ago
Comment on attachment 453380 [details]
flashblock.xml: Use !important for our backbround images

This does the trick for dailymotion. I went to a bunch of flash filled sites, from youtube to your grandmother's blog without noticing any (display) issues.

(I didn't try myspace.com :-))
Attachment #453380 - Flags: feedback?(phiw) → feedback+
Created attachment 453615 [details] [diff] [review]
Part 1: Upgrade to Flashblock 1.5.13

While getting Philip's changes into a patch, I realized we seem to have missed an upgrade to Flashblock 1.5.13.  Rather than lump everything into one patch/commit (which is probably OK here, but it offends my sense of order :P), this patch first upgrades us to Flashblock 1.5.13 (changes to the .xml, the .css, and our README; note the deleted "contents.rdf" stuff still applies to 1.9.0-based branches, so that will differ across branches).
Attachment #453615 - Flags: superreview?(stuart.morgan+bugzilla)
Created attachment 453617 [details] [diff] [review]
Part 2: Upgrade to latest flashblock.xml from Philip Chee

This is Philip's flashblock.xml above plus our README change.  I called it "flashblock-unstable.xpi plus the fix for bug 573815" because the fix here 1) is not yet available in the unstable.xpi (but it might be before we land this, I suppose) and 2) because there are other changes beyond 1.5.13 also present.

For the sake of completeness, I'll also attach a hacked-up (do not try to apply, do not review) diff that shows just the changes between -unstable and the above .xml (i.e., just the hunks that are changes to fix this bug), but I only intend to land in two parts: 1.5.13 and latest-flashblock.xml.
Attachment #453617 - Flags: superreview?(stuart.morgan+bugzilla)
Created attachment 453618 [details] [diff] [review]
For reference only: just the changes that fix this bug

As mentioned above, this is the hack-diff that shows just the changes made to flashblock.xml to fix this bug (not for review/applying/landing).
Er, that should be "flashblock-1.5.unstable.xpi" in the README in Part 2; I'll fix that before landing.

Comment 13

7 years ago
Comment on attachment 453615 [details] [diff] [review]
Part 1: Upgrade to Flashblock 1.5.13

sr=smorgan x2
Attachment #453615 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+

Updated

7 years ago
Attachment #453617 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+
http://hg.mozilla.org/camino/rev/b1906107efdc
http://hg.mozilla.org/camino/rev/6d411536d7dc

Thanks again for the quick fix, Philip!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Also on CVS trunk and CAMINO_2_0_BRANCH.
Flags: camino2.0.4? → camino2.0.4+
Whiteboard: [camino-2.0.4]
You need to log in before you can comment on or make changes to this bug.