Add "X-Bugzilla-*" headers to flagmails

RESOLVED FIXED in Bugzilla 5.0

Status

()

--
enhancement
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: andre.txt, Assigned: mail)

Tracking

3.6.3
Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: ver 3.4.6 (ru: 3.4.3)

I received a letter from the "Requests". There is no possibility to filter the header "X-Bugzilla-Product"

Reproducible: Always

Actual Results:  
No header "X-Bugzilla-Product" in the letter "Requests"

Expected Results:  
is the header of "X-Bugzilla-Product" in the letter "Requests"
Dupe of bug 390586?
(Reporter)

Comment 2

8 years ago
I do not think that it is Duplicate.

Comment 3

8 years ago
(In reply to comment #0)
> I received a letter from the "Requests".

What is that?? A flag mail?
(Reporter)

Comment 5

8 years ago
(In reply to comment #3)
> What is that?? A flag mail?
X-Bugzilla-Type: request
(Reporter)

Comment 6

8 years ago
Help solve the problem?
Because of this problem, I can not sort the letters ("Requests") by the field Product.
(Reporter)

Comment 7

8 years ago
Why "UNCONFIRMED"?

Comment 8

8 years ago
Let me translate again :-)

request/email.txt.tmpl does not include X-Bugzilla-Product: header.  Also, product is not passed in template call.  Yes one can dig product out of bug object anyway, but it is rather tricky for average Bugzilla customizer.

source: http://forum.mozilla-russia.org/viewtopic.php?id=44812

AFAICT it is not a duplicate of bug 390586 because this bug affects any recipient, not just Cc:
Severity: enhancement → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Summary: The letter "Requests" does not contain "X-Bugzilla-Product" → Flag mail lacks "X-Bugzilla-Product:" header
Version: unspecified → 3.6.3
(Reporter)

Comment 9

8 years ago
(In reply to comment #8)
> Let me translate again :-)

Good :-)
(Assignee)

Comment 10

6 years ago
Created attachment 686520 [details] [diff] [review]
patch to change header
Attachment #686520 - Flags: review?
Comment on attachment 686520 [details] [diff] [review]
patch to change header

Review of attachment 686520 [details] [diff] [review]:
-----------------------------------------------------------------

I am reluctant to r+ this one as it will not stop with Product. If you add that, people will want more of the bug attributes
added until we have the same amount as normal bugmail. Flag emails were meant to be simple notifications to the requestee that
they need to address the requested flag. And not meant to be a normal bug email. Those are sent separately which do have all of
the proper headers.

That being said, I can see they need to be able to filter the flag emails on the client side so I am open to discussing further.
LpSolit, what do you think? Should we add the product header and additionally component and version maybe?

dkl

Comment 12

6 years ago
(In reply to David Lawrence [:dkl] from comment #11)
> LpSolit, what do you think? Should we add the product header and
> additionally component and version maybe?

If we follow this path, we are going to duplicate all headers from email/bugmail-header.txt.tmpl, which is something we agree we don't want to see happening. In that case, it would make more sense to share the code with email/bugmail-header.txt.tmpl than to duplicate everything. So I agree with you to not approve this patch.
Severity: minor → enhancement

Comment 13

6 years ago
Comment on attachment 686520 [details] [diff] [review]
patch to change header

r- due to the two previous comments.
Attachment #686520 - Flags: review? → review-
(Assignee)

Comment 14

6 years ago
Created attachment 687023 [details] [diff] [review]
Updated patch to address last two comments
Attachment #686520 - Attachment is obsolete: true
Attachment #687023 - Flags: review?(dkl)
Comment on attachment 687023 [details] [diff] [review]
Updated patch to address last two comments

Review of attachment 687023 [details] [diff] [review]:
-----------------------------------------------------------------

I think it would better if we named the new template 'header-common.txt.html' for consistency with other template naming.

Attach new patch with changed filename then r+ since everything else looks fine and worked as expected for me.

::: template/en/default/email/bug-header.txt.tmpl
@@ +4,5 @@
> +  #
> +  # This Source Code Form is "Incompatible With Secondary Licenses", as
> +  # defined by the Mozilla Public License, v. 2.0.
> +  #%]
> +  

Remove extra whitespace here
Attachment #687023 - Flags: review?(dkl) → review-
(Assignee)

Comment 16

6 years ago
(In reply to David Lawrence [:dkl] from comment #15)
> I think it would better if we named the new template
> 'header-common.txt.html' for consistency with other template naming.

I assume you meant .txt.tmpl, which I have done.
 
> Remove extra whitespace here

Done
(Assignee)

Comment 17

6 years ago
Created attachment 687251 [details] [diff] [review]
Updated patch to address last comment
Attachment #687023 - Attachment is obsolete: true
Attachment #687251 - Flags: review?
(Assignee)

Updated

6 years ago
Attachment #687251 - Flags: review? → review?(dkl)
Comment on attachment 687251 [details] [diff] [review]
Updated patch to address last comment

Review of attachment 687251 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine and works as expected. r=dkl
Attachment #687251 - Flags: review?(dkl) → review+

Updated

6 years ago
Assignee: attach-and-request → hugo.seabrook
Status: NEW → ASSIGNED
Flags: approval+
Keywords: relnote
Summary: Flag mail lacks "X-Bugzilla-Product:" header → Add "X-Bugzilla-*" headers to flagmails
Target Milestone: --- → Bugzilla 5.0
Thanks for the patch!

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunk
modified template/en/default/email/bugmail-header.txt.tmpl
modified template/en/default/email/flagmail.txt.tmpl
added template/en/default/email/header-common.txt.tmpl
Committed revision 8509.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: Bugzilla 5.0 → ---

Updated

6 years ago
Target Milestone: --- → Bugzilla 5.0

Updated

6 years ago
Duplicate of this bug: 846484

Comment 21

5 years ago
(In reply to Andrey from comment #2)
> I do not think that it is Duplicate.

It is definitely a duplicate.

Updated

5 years ago
Duplicate of this bug: 390586

Comment 23

4 years ago
Added to relnotes for 5.0rc1.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.