LXR doesn't find files with a space in the name.

RESOLVED FIXED

Status

Webtools
MXR
P3
normal
RESOLVED FIXED
17 years ago
12 years ago

People

(Reporter: David Krause, Assigned: timeless)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

433 bytes, patch
Christian Reis
: review+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
LXR doesn't show this file when doing the above query:
http://lxr.mozilla.org/seamonkey/source/embedding/browser/powerplant/PP%20Browser.mcp

It does however find directories with a space in them.

Comment 1

17 years ago
files checked in to the tree shouldn't have spaces in their file
names. This file was initially checked in by conrad. Could you
please rename the file?

reassigning to conrad.
Assignee: endico → conrad
Component: LXR → Build Config
Product: Webtools → Browser
(Assignee)

Comment 2

17 years ago
Endico, this bug's for you. we already have bugs on the files themselves. This 
one was filed for lxr/bonsai robustness.  Please reaccept and mark wontfix if 
you feel that is the appropriate solution.
(Reporter)

Comment 3

17 years ago
Endico, this bug was for you so that LXR could be fixed to not choke on file
names with spaces.  Bug 57389 was already filed for the specific file in the
tree with a space.  I will assign that bug to Conrad.
Assignee: conrad → endico
Component: Build Config → LXR
Product: Browser → Webtools
(Assignee)

Comment 4

17 years ago
if find were patched to use 'directory\ restofdirectory/file\ spaced.extention' 
format? and would that fix the problem w/ some scripts?
(Assignee)

Comment 5

16 years ago
*** Bug 92371 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

14 years ago
Created attachment 136547 [details] [diff] [review]
handle +
(Assignee)

Updated

14 years ago
(Assignee)

Comment 7

14 years ago
Comment on attachment 136547 [details] [diff] [review]
handle +

http://landfill.mozilla.org/mxr-test/seamonkey/find?string=+
Attachment #136547 - Flags: review?(kiko)

Comment 8

14 years ago
Comment on attachment 136547 [details] [diff] [review]
handle +

I wonder if we would be better off urldecoding this thing..

This patch changes the search semantics slightly, since +s were originally
ignored (i.e. searching for "Mozilla+Browser" returns files with
"MozillaBrowser" in them, but I don't see that as a valid or expected use case
so I'm okay with it going away.
Attachment #136547 - Flags: review?(kiko) → review+
(Assignee)

Comment 9

14 years ago
mozilla/webtools/lxr/find 	1.8
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
QA Contact: mattyt-bugzilla → lxr
You need to log in before you can comment on or make changes to this bug.