bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Unable to mark filter edited just before

RESOLVED INVALID

Status

MailNews Core
Filters
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Veljko Popovic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Once I edit filter (add some new address to the list), press OK and edit window closes, I'm unable to select last filter in Message Filters dialog. Since last edited filter is on the bottom of select box, I can not reach last edited filter to move it or apply it. This problem goes away once I close the window and open it again....

Reproducible: Always

Steps to Reproduce:
1. Add new e - mail address to existing filter
2. Press OK and close Edit filter dialog
3. Try to select edited filter via mouse or keyboard
Actual Results:  
Unable to select message filter

Expected Results:  
To be able to select message filter
Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)

Anything in tools -> Error console when this happens ?
Component: Mail Window Front End → Filters
Product: Thunderbird → MailNews Core
QA Contact: front-end → filters
(Reporter)

Comment 2

8 years ago
Nothing in Error Console ... In Safe Mode behaves as I would expect it: I'm capable to select previously edited rule ....
(In reply to comment #2)
> Nothing in Error Console ... In Safe Mode behaves as I would expect it: I'm
> capable to select previously edited rule ....

So one of your installed extension or theme is screwing things up. Try disabling one of them at a time until you find the culprit. Notify the extension/theme author so he can fix this.

Resolving as invalid as this works in -safe-mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

8 years ago
OK, I'm using default theme, I have made no changes regarding visual appearance in my thunderbird ..........

Comment 5

8 years ago
(In reply to comment #4)
> OK, I'm using default theme, I have made no changes regarding visual appearance
> in my thunderbird ..........

If you can reproduce this and it's not a theme, then it's an add-on. :)
I would be helpful if you can narrow it to a specific add-on and post the name here. If you don't have any add-ons installed, then more investigation is needed.

Comment 6

8 years ago
safe-mode also reverts some settings to their defaults, iirc.
(Reporter)

Comment 7

8 years ago
Ok, that's it ... I had Thunerbird message filter export/import and lightning add - ons installed on previous version of TB ... After migration to a new version, no add - ons are removed (i got ons I had before migration). I uninstalled them and problem seems resolved. On the other hand, I have managed to install message filter export/import, but I was not able to find lightning ... I have a pure install of TB on my linux machine (no add-ons at all) and everything seems OK, so lightning is probably guilty one ......

Comment 8

8 years ago
(In reply to comment #7)
> everything seems OK, so lightning is probably guilty one ......

that seems too, too strange, that message filter export wasn't the cause.
can you reproduce if if you reinstall one, or both?
You need to log in before you can comment on or make changes to this bug.