Crashes with Last pass addon on trying to edit passwords/user names in Lastpass (no primaryColumn) [@ nsCoreUtils::IsColumnHidden]

RESOLVED FIXED

Status

()

Core
Disability Access APIs
--
critical
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: rajsudhakaran@gmail.com, Assigned: timeless)

Tracking

({crash})

1.9.2 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4

Firefox 3.6.4 Build 7 with Last pass addon 1.68.2

Scenario: 
1. Firefox browser window is open and surfing.
2. while lastpass search is activated by pressing "alt + w"
3. Trying to hit edit button on lastpass search window crashes the browser.
4. Report submitting window appears and browser restarts,


Reproducible: Sometimes

Actual Results:  
After 4 attempts of continuing to hit edit button on last pass search window, it did not crash, but with same try it crashed on 7th time.


The software would have asked me for a master password window and through which i could log in to my Last pass account.
(Reporter)

Comment 1

8 years ago
Created attachment 453329 [details]
screenshot of Lastpass window before crashing
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 3

8 years ago
Created attachment 453970 [details]
Crash report of Firefox crashes from last one day with last pass addon

Submitted Crash Reports		
		
Report ID	                        Date            Submitted	
    		
8cd9f6ba-f99c-4b54-892c-119a6409a676	25-Jun-10	11:04 AM
bp-f0c8ae24-c1a5-4917-9dd0-d910b2100624	25-Jun-10	11:04 AM
bp-6f590a7e-096c-4468-b732-48abe2100624	25-Jun-10	11:01 AM
bp-8d2800ff-df15-4d64-9bc1-0c8c72100624	24-Jun-10	5:51 PM
bp-328c2e85-104f-4990-8b17-8c1552100624	24-Jun-10	3:47 PM
bp-3a4555ef-7f44-454f-ad07-44ccf2100623	24-Jun-10	10:29 AM
bp-b957d837-8253-46af-bc0f-7048e2100623	24-Jun-10	10:25 AM
bp-2f4e328d-deac-415e-8c01-01fa12100623	23-Jun-10	2:52 PM
bp-f0cb1ef2-b831-4952-ab15-7d4db2100623	23-Jun-10	2:39 PM
bp-cf3a4394-8ab5-4acb-a779-be3fa2100623	23-Jun-10	2:39 PM
(Assignee)

Comment 4

8 years ago
Signature	nsCoreUtils::IsColumnHidden(nsITreeColumn*)
UUID	f0c8ae24-c1a5-4917-9dd0-d910b2100624
Time 	2010-06-24 22:34:18.491664
Uptime	37
Last Crash	125 seconds before submission
Install Age	779575 seconds (1.3 weeks) since version was first installed.
Product	Firefox
Version	3.6.4
Build ID	20100611143157
Branch	1.9.2
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 37 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
User Comments	Firefox crashed again while accessing Lastapss addon 1.68.2, 2ce74140-7eac-489f-8a0e-adced735a21c [Bug 573934] Firefox 3.6.4 Build 7 crashes with Last pass addon on trying to edit passwords/user names in Lastpass
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsCoreUtils::IsColumnHidden 	accessible/src/base/nsCoreUtils.cpp:1105
1 	xul.dll 	nsXULTreeItemAccessibleBase::IsExpandable 	accessible/src/xul/nsXULTreeAccessible.cpp:1210
2 	xul.dll 	nsXULTreeItemAccessibleBase::GetStateInternal 	accessible/src/xul/nsXULTreeAccessible.cpp:1125
3 	xul.dll 	nsAccessible::GetState 	accessible/src/base/nsAccessible.cpp:1911
4 	xul.dll 	nsXULElement::GetAttr 	content/xul/content/src/nsXULElement.cpp:1226
5 	xul.dll 	nsRootAccessible::FireAccessibleFocusEvent 	accessible/src/base/nsRootAccessible.cpp:484
6 	xul.dll 	nsRootAccessible::HandleEventWithTarget 	accessible/src/base/nsRootAccessible.cpp:820
7 	xul.dll 	nsRootAccessible::HandleEvent 	accessible/src/base/nsRootAccessible.cpp:598
Component: General → Disability Access APIs
Keywords: crash
Product: Firefox → Core
QA Contact: general → accessibility-apis
Summary: Firefox 3.6.4 Build 7 crashes with Last pass addon on trying to edit passwords/user names in Lastpass → Firefox 3.6.4 Build 7 crashes with Last pass addon on trying to edit passwords/user names in Lastpass [@ nsCoreUtils::IsColumnHidden]
Version: unspecified → 1.9.2 Branch
(Assignee)

Updated

8 years ago
Summary: Firefox 3.6.4 Build 7 crashes with Last pass addon on trying to edit passwords/user names in Lastpass [@ nsCoreUtils::IsColumnHidden] → Crashes with Last pass addon on trying to edit passwords/user names in Lastpass (no primaryColumn) [@ nsCoreUtils::IsColumnHidden]
(Assignee)

Comment 5

8 years ago
Created attachment 453989 [details] [diff] [review]
patch
Assignee: nobody → timeless
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #453989 - Flags: review?(surkov.alexander)

Updated

8 years ago
Attachment #453989 - Flags: review?(surkov.alexander) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Comment 6

8 years ago
landed on 1.9.3 - http://hg.mozilla.org/mozilla-central/rev/0368fa748260
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Duplicate of this bug: 591009
(Assignee)

Comment 8

7 years ago
Comment on attachment 453989 [details] [diff] [review]
patch

we're still crashing on branches
Attachment #453989 - Flags: approval1.9.2.15?
(Assignee)

Updated

7 years ago
Duplicate of this bug: 630749
Comment on attachment 453989 [details] [diff] [review]
patch

Approved for 1.9.2.15, a=dveditz for release-drivers
Attachment #453989 - Flags: approval1.9.2.15? → approval1.9.2.15+
Comment on attachment 453989 [details] [diff] [review]
patch

non-blocker and missed the 1.9.2.16 code-freeze, removing approval
Attachment #453989 - Flags: approval1.9.2.16+ → approval1.9.2.16-
Crash Signature: [@ nsCoreUtils::IsColumnHidden]
You need to log in before you can comment on or make changes to this bug.