Visiting a .asp site firefox ask you to save it

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Black_Ps`, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4

I received a phishing site on my e-mail http://www.signin.ebay.com.dll.pochta.ru/ehayISAPIdllSignInruhttwwwehaycomtrksidm.asp when i visit it ,firefox is the only one that asks me to save it,opera can display it,iexplore can display it,firefox why not? 

Reproducible: Always

Comment 1

8 years ago
That's because it's send with the Content-Type application/octet-stream, not text/html as it should be. That's the fault of the webserver. FF respects the standard, the other browser use content-sniffing to override such misconfigurations.

I wouldn't bet on contacting the webmaster to fix this, though :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
k,thanks.
You need to log in before you can comment on or make changes to this bug.