When receiving new email from popup, item appears twice (once from all mail and once from Inbox)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
6 years ago

People

(Reporter: matthew.krummert, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: 3.0.5

When recieving new email from popup, item appears twice (once from all mail and once from Inbox)

Reproducible: Always

Steps to Reproduce:
1. Receive mail
2.Notice in popup that there are two messages received
3.
Actual Results:  
Two messages appear instead of one

Expected Results:  
One message should appear for each message
Gmail IMAP?

Gmail IMAP puts new mail in both Inbox and [Gmal]/All Mail(mail in [Gmail]/All Mail can be said "copy of mail" from user's view). This is design of Gmail/Gmail IMAP. If Gmail IMAP, please read next document well and Gmail's guide such as Gmail Help before open Gmail IMAP related bug at B.M.O.
> http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

For mail client, mails in these two IMAP folder are different mails(independent folder, independent UID). If you don't want new mail alert on [Gmail]/All Mail, you need to stop automatic mail check of [Gmail]/All Mail.
(Reporter)

Comment 2

9 years ago
If I understand your comment you are staiting that this is an issue with how Gmail works and not Thunderbird which I agree with, however I think that this issue can still easily be resolved.  If I understand things correctly, you are putting a timer in Thunderbird to check to see if there is mail ever X minutes, thus it is possible but not likely that you will have part of a piece of mail come in on two periods.  Since we are now going to recieve both messages at once the majority of times, what if you did a test of all new mail to see if there is one in the all mail folder that is also in another folder such as the inbox before displaying it to the user?
Before asking questions and suggesting some changes of Tb, please understand Gmail IMAP particularity well and understand RFC for IMAP first, please.
Have you read and understood all Gmail Help documents pointed by "External links"/"Gmail Help articles you have to read before you start using Gmail IMAP" links in Mozillazine Knowledge Base document I pointed in comment #1?
Have you read and understood RFC for IMAP Version 4 Rev.1?
Matthew Krummert, please read and understand all bugs listed in Dependency tree for meta bug 402793 with "Show Resolved" before asking questions and suggesting some changes of Tb.
Duplicate of this bug: 600963
reporter, do you still see this problem when using a current version?
Component: General → Untriaged
Whiteboard: [closeme 2012-12-10]

Comment 7

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-12-10]
You need to log in before you can comment on or make changes to this bug.