Unexpected / new / undesired search behavior

RESOLVED WORKSFORME

Status

Thunderbird
Search
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Peter Karp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

The following behavior is new to Thunderbird as of approximately
April or May 2010.  I find this behavior unexpected, undesired,
and hard to control.

Normally in the search box in the upper right I have 
"Subject or From Filter" selected.  However, SOMETIMES (not always),
when I start Thunderbird and then do a search (it always seems to
happen on my first search after startup), the search behaves
differently than I expect.  It opens a new tab, it creates a tiny
status "window" of sorts saying "Searching" and it takes a long time
to execute that search.  If I think re-select "Subject or From Filter"
and try the search again, it still does the same thing.  I have
to do that re-selection several times, and keep closing the new tab,
before this behavior goes away.  

I find this behavior very confusing, hard to get rid of, too slow,
and I don't want it.  Please get rid of it!


Reproducible: Sometimes

Comment 1

7 years ago
This is probably fixed in Thunderbird 3.1, since the filters (as opposed to the global search that opens in its own tab) have their own dedicated search box now.
Peter does upgrading to 3.1 fixes your issue ?
(Reporter)

Comment 3

7 years ago
Yes, it does.  Nicely done, I like the new interface as well
with the buttons to show which fields the search applies to.
I'll close the bug, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.