Thunderbird hogs CPU, often unusable

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Peter Karp, Unassigned)

Tracking

({perf})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

General background: Thunderbird has taken a big turn for the worse as
of roughly 4-8 weeks ago when a new release came out that caused the
program to run extremely slowly.  A lot of that seemed to be due to
indexing of mail files, which I have turned off (I think).

But still the program runs extremely slowly, and I realize it has been
hogging one of the two CPUs on my laptop quite reliably.

To reproduce, simply start Thunderbird and wait several minutes.
High CPU usage does not begin right away.  I also do not no if it
happens every time, but it happens a large fraction of the time.

You had best fix this soon or you will find yourselves losing a lot
of users, the program is VERY slow and virtually unusable.




Reproducible: Sometimes

Comment 1

8 years ago
Peter, please go through the information and list of steps at https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems and report your results.

Updated

8 years ago
Severity: critical → major
Keywords: perf
Version: unspecified → 3.0
(Reporter)

Comment 2

8 years ago
More info:

As I monitor my system more carefully, I find this behavior starts
every time I start Thunderbird, usually within 1 minute of when I
start it.  It happened at least a dozen times today.
Also, memory usage increases.  I watched it grow by
100MB per minute; I stopped it when it reached 800MB.

Regarding your request that I go through the above list of steps,
here is what I have found so far.

1. My tbird profile is on my computer, not on a network drive.

2. I am not allowed to turn off my anti-virus software, says my
employer.  I have not changed that software lately, although it
may be subject to automatic updates.

4. I do have a gmail account, but could not figure out what was meant
by unsubscribing from the All Mail folder.  What I did was to delete
the gmail account from tbird and restart, and the problem was still
there.

6. I don't use newsgroups

7. I don't use a calendar


This is all I have time for now.

What I do observe is that now tbird is NOT going into this CPU hogging
mode on me, i.e., after two tries I cannot replicate the problem.  I
wonder if it has finished indexing a folder.

I will note that the remaining steps listed look very time
consuming for me to take on.  Perhaps it would be more helpful if
there was a way of turning on logging of what threads are active at
any given time and what they are doing.  Obviously some thread is
out of control.  Perhaps this is what #11 does.  If the problem
comes back, I will try it.

Comment 3

8 years ago
(In reply to comment #2)
> More info:
> 
> As I monitor my system more carefully, I find this behavior starts
> every time I start Thunderbird, usually within 1 minute of when I
> start it.  It happened at least a dozen times today.
> Also, memory usage increases.  I watched it grow by
> 100MB per minute; I stopped it when it reached 800MB.
> 
> Regarding your request that I go through the above list of steps,
> here is what I have found so far.
> 
> 1. My tbird profile is on my computer, not on a network drive.
> 
> 2. I am not allowed to turn off my anti-virus software, says my
> employer.  I have not changed that software lately, although it
> may be subject to automatic updates.

which AV software??
also, it is sometimes possible to override specific features, like unprotecting a specific folder

> 4. I do have a gmail account, but could not figure out what was meant
> by unsubscribing from the All Mail folder.  What I did was to delete
> the gmail account from tbird and restart, and the problem was still
> there.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite#Subscriptions

 
> 6. I don't use newsgroups
> 
> 7. I don't use a calendar
> 
> 
> This is all I have time for now.
> 
> What I do observe is that now tbird is NOT going into this CPU hogging
> mode on me, i.e., after two tries I cannot replicate the problem.  I
> wonder if it has finished indexing a folder.

don't forget #5, which is as quick as simply restarting thunderbird.

> I will note that the remaining steps listed look very time
> consuming for me to take on.  Perhaps it would be more helpful if
> there was a way of turning on logging of what threads are active at
> any given time and what they are doing.  Obviously some thread is
> out of control.  Perhaps this is what #11 does.  If the problem
> comes back, I will try it.

there is no such thing

Comment 4

7 years ago
I'm going to take comment 2  "... if the problem comes back" as WFM.

If you still see speed problems, please finish out the wiki document, and consider some of these perf bugs https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&keywords=perf&keywords_type=allwords&field0-0-0=short_desc&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&type0-0-1=substring&field0-0-1=keywords&type1-0-1=allwordssubstr&resolution=---&classification=Client%20Software&classification=Components&query_format=advanced&type0-0-0=anywordssubstr&component=General&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.