dwrite font code does not get digit width correctly

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 453446 [details] [diff] [review]
patch, v1 - correctly test for success of the dwrite call

Mentioned by Bas on irc, but I don't see a bug filed: the dwrite font code fails to get the width of the "zero" glyph as intended.

(This shows up as a reftest failure in forms/input-text-size-1.html because the width of the input field is based on the digit width.)
Attachment #453446 - Flags: review?(bas.schouten)
(Assignee)

Updated

9 years ago
Attachment #453446 - Attachment description: patch, v1 → patch, v1 - correctly test for success of the dwrite call
(Assignee)

Updated

9 years ago
Blocks: 549832
Attachment #453446 - Flags: review?(bas.schouten) → review+
(Assignee)

Comment 1

9 years ago
http://hg.mozilla.org/mozilla-central/rev/50f755860783
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.