Error in chrome://browser/content/places/placesOverlay.xul causes error in Jetpack test suite when running Firefox in XULRunner mode

RESOLVED DUPLICATE of bug 581109

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 581109
8 years ago
7 years ago

People

(Reporter: adw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
On OS X and Firefox 3.7, `cfx testall` and `cfx test` generate this error:

console: [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://browser/content/places/placesOverlay.xul :: <TOP_LEVEL> :: line 25"  data: no]"]

Any logged error causes the Jetpack test harness to increment the number of failed tests even if the error has nothing to do with Jetpack, like this one doesn't.

This error only occurs when running Firefox 3.7 in XULRunner mode on OS X.  The problem is that the browser chrome is available to the app (which seems like a bug, since Firefox is being run with -app and not "as Firefox") while the browser modules are not.  placesOverlay.xul in particular is overlaid onto /browser/base/content/macBrowserOverlay.xul, which is overlaid onto /browser/base/content/hiddenWindow.xul, which is opened from nsAppShellService::CreateHiddenWindow [1].  When placesOverlay.xul tries to load a browser module (resource:///modules/PlacesUIUtils.jsm), it naturally fails, causing the error.

Atul, can whitelist this particular error so it doesn't needlessly freak people out?

[1] http://mxr.mozilla.org/mozilla-central/source/xpfe/appshell/src/nsAppShellService.cpp#161

Comment 1

8 years ago
Hmm, I thought Dietrich had filed this bug a while ago, and that the platform team was working on fixing it... I can't find the bug now though, unfortunately. I could try fixing it, but my only concern is making sure the filtering isn't overly general (thereby masking real errors) or overly fragile.

Comment 2

8 years ago
Note that if we fix bug 581109, this gets automatically fixed too.
Depends on: 581109

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581109
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.