If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 3.6.4 crashes due to "Flash No Longer Crashes" update Flash sites crash

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
critical
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: anonmalfu, Unassigned)

Tracking

({flashplayer, hang, stackwanted})

1.9.2 Branch
x86
Windows Vista
flashplayer, hang, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 GTB7.1 (.NET CLR 3.5.30729)

Computer had 3.6.4 firefox installed. 
Adobe flashed complained to be updated. 
Firefox just hangs and doesn't stops working.

Reproducible: Always

Steps to Reproduce:
Load a video on youtube, do not enjoy your video.
Actual Results:  
Video starts playing, audio continues video feed stops and freezes. Mouse has the link cursor on and you can't get it off, click anywhere on firefox, firefox doesn't respond to anything, nothing works, everything is frozen, it is broken.

Expected Results:  
Video on youtube plays, and no new account is created on bugzilla.

It should have worked like it did before the update. It was FINE before.
(Reporter)

Updated

7 years ago
Keywords: crash, flashplayer, hang
Summary: Video plays for 20 seconds, audio continues video stops firefox becomes unresponsive → Firefox 3.6.4 crashes due to "Flash No Longer Crashes" update Flash sites crash
(Reporter)

Comment 1

7 years ago
This is not a fix to firefox as it will always crash on this but this is a solution that I offer to others who are unable to find the solution due to poor SEO.

The solution lies in disabling the No crashing update that firefox has thrown in our throats

About:config
void warranty 

seach for ipc
disable everything that shows up, should be the following:

dom.ipc.plugins.enable - change to false
dom.ipc.plugins.enable.npctrl.dll - change to false
dom.ipc.plugins.enable.npqtplugin.dll - change to false
dom.ipc.plugins.enable.npswf32.dll - change to false
dom.ipc.plugins.enable.nptest.dll - change to false

This will stop firefox from trying to stop itself from crashing and thus crashing. Hope this is fixed in the future as this is inconvienent.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 2

7 years ago
what version of flash do you have?

https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_windbg
Component: General → Plug-ins
Keywords: crash → stackwanted
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.2 Branch
You need to log in before you can comment on or make changes to this bug.