unable to update from 3.6.3 -> 3.6.4 with the UI stuck in the paused state

RESOLVED DUPLICATE of bug 539717

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 539717
8 years ago
8 years ago

People

(Reporter: Seth Spitzer, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
stuck in software update

I'm currently stuck going from 3.6.3 -> 3.6.4 on Mac OS X.

in /Applications/Firefox.app/Contents/MacOS/updates:

Macintosh-4:updates sspitzer$ ls -alt 0/*
-rw-r--r--@ 1 sspitzer  sspitzer       5 Jun 24 09:18 0/update.status
-rw-r--r--@ 1 sspitzer  sspitzer       5 Jun 24 09:18 0/update.version
-rw-------@ 1 sspitzer  sspitzer  300000 Jun 23 08:50 0/update.mar
Macintosh-4:updates sspitzer$ pwd
/Applications/Firefox.app/Contents/MacOS/updates
Macintosh-4:updates sspitzer$ cat 0/update.status 
null
Macintosh-4:updates sspitzer$ cat 0/update.version 
null

it looks like I only got one chunk of the mar, and I now I'm stuck?

see attached screen shot.

note, this persists even after restart.
(Reporter)

Comment 1

8 years ago
Created attachment 453751 [details]
screen shot

rob, let me know if you need any addition details.
(Reporter)

Comment 2

8 years ago
Created attachment 453752 [details]
here is my /Applications/Firefox.app/Contents/MacOS/updates.xml file
(Reporter)

Comment 3

8 years ago
Created attachment 453753 [details]
here is my /Applications/Firefox.app/Contents/MacOS/active-update.xml file
(Reporter)

Comment 4

8 years ago
looking at active-update.xml, I remember attempting to get the partial, and it failed, and then trying to get the whole pig.
(Reporter)

Updated

8 years ago
Summary: stuck in software update → stuck in software update, unable to go from 3.6.3 -> 3.6.4
Hey Seth, I highly suspect this is bug 539717. The steps to check if it is in this scenario are rather long so I'll post them after I flush the simplest way out.
Summary: stuck in software update, unable to go from 3.6.3 -> 3.6.4 → unable to update from 3.6.3 -> 3.6.4 with the UI in the paused state
Summary: unable to update from 3.6.3 -> 3.6.4 with the UI in the paused state → unable to update from 3.6.3 -> 3.6.4 with the UI stuck in the paused state
(Reporter)

Comment 6

8 years ago
> Hey Seth, I highly suspect this is bug 539717. The steps to check if it is in
> this scenario are rather long so I'll post them after I flush the simplest way
> out.

Thanks for the response, Rob.  Just let me know what I can do to help.
Seth, could you attach the update.status file? Thanks
(Reporter)

Comment 8

8 years ago
> Seth, could you attach the update.status file? Thanks

I can't until later tonight, but until then:

-rw-r--r--@ 1 sspitzer  sspitzer       5 Jun 24 09:18 0/update.status

Macintosh-4:updates sspitzer$ cat 0/update.status 
null

Does that help?
That points to this being a duplicate of bug 539717. Before 3.6 we always removed the update dirs and files on startup if the file didn't exist or it contained 'null'. With 3.6 it only removed the files (no longer remove the dirs to improve perf on mobile) when the file didn't exist. With bug 539717 fixed it removes the files when the file doesn't exist or contains 'null'. I am quite certain this is a dupe of bug 539717. Though the code should probably do a better job of restarting the download of the update in the same session I'm not sure how I want to go about that at this time and the behavior prior to 3.6 which is restored in 3.6.4 is a known quantity which avoids the break app update == pink slip issue.
btw: just remembered the main reason the directory was no longer deleted. On WinCE / WinMo deleting and then immediately recreating the directory screwed up the filesystem in that the directory could not be opened. Resolving -> duplicate of bug 539717
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539717
(Reporter)

Comment 11

8 years ago
thanks robert.  so should I just remove the update dirs?
(Reporter)

Comment 13

8 years ago
for the record, removing 
/Applications/Firefox.app/Contents/MacOS/updates/0 was not enough, I had to also remove /Applications/Firefox.app/Contents/MacOS/active-update.xml 

I'm not sure if removing /Applications/Firefox.app/Contents/MacOS/active-update.xml alone would have fixed it.

Thanks again Rob.
You need to log in before you can comment on or make changes to this bug.