Drilling down/filtering by application version passes invalid pagination number/value

VERIFIED FIXED in 5.11.3

Status

--
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: stephend, Assigned: davedash)

Tracking

unspecified
5.11.3

Details

(URL)

(Reporter)

Description

8 years ago
Sorry for the summary; no idea what's going on or how to best describe this

STR:

Load https://preview.addons.mozilla.org/z/en-US/firefox/search/?sort=weeklydownloads&pp=20&atype=0&pid=1&cat=1%2C4&q=DOM&lver=3.5&page=3&advanced=off

Actual:

"Showing 1 - 20 of 36 results for DOM

No results found"
Depends on: 574475

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 1

8 years ago
Reopening, since I know why this happens:

1. Search for "DOM" in "Web Development": https://preview.addons.mozilla.org/en-US/firefox/search/?q=dom&cat=1%2C4&lver=any&atype=0&sort=&pid=1&pp=20&lup=&advanced=
2. Currently, you'll get 47 results; note the pagination
3. Click on page 3
4. Now click on the "3.7" version in "Compatible with:"

The problem here seems to be that page=3 is passed, when the # of 3.7-compatible add-ons named "DOM" in the "Web Development" category is 8, so with a default per-page (pp=) of 20, there is no page 3.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Odd mix of results and "no results found" messaging on search results → Drilling down/filtering by application version passes invalid pagination number/value
Should have been a new bug, but good find:

http://github.com/davedash/zamboni/compare/master...remove-pagination-574456
Status: REOPENED → ASSIGNED
Whiteboard: [r?clouserw]
Assignee: nobody → dd
(Reporter)

Comment 3

8 years ago
Why should it have been a new bug?  It's the same URL...
It was originally about missing results.  Not it's about paginating filters.

Sadly we sometimes have more than one bug on any given url :(
(Reporter)

Comment 5

8 years ago
Oh, well, it was never "fixed" (as it was so marked) -- bringing the two Sphinx nodes together never brought us results, so retargeting the bug to the only reproducible issue on the original URL didn't seem like a stretch at all to me.
yeah no worries, at lest it wasn't one of those bugs with a million little issues and 100 comments.
http://github.com/jbalogh/zamboni/commits/33dfda4
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: [r?clouserw]
(Reporter)

Comment 8

8 years ago
Verified FIXED, thanks!
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.