moving mouse over context menu items causes incorrect flickering hover mode between nav toolbar widget and context menu items.

RESOLVED DUPLICATE of bug 575162

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 575162
8 years ago
8 years ago

People

(Reporter: [not reading bugmail], Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100624 Minefield/3.7a6pre Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100624 Minefield/3.7a6pre Firefox/3.6.4

Menu items don't show proper menu hover color when highlighting menu option like  Delete.  When moving the mouse to another menu item, the bookmarks widget in the navigation toolbar flickers hover mode as if you were mousing over the widget at the same time as the context menu.


Reproducible: Always

Steps to Reproduce:
1. Opening new Bookmarks widget (arrow menu widget from Nav bar)
2. When Bookmarks Toolbar is closed, open the bookmarks menu
3. right click on regular bookmark and open context menu
3. mouse over multiple menu items and watch hover state changes



Actual Results:  
Mousing over context menu doesn't show hover state, only between menu options the hover state goes on when mousing out of a menu option, but the widget shows it instead hovered all the time, this is incorrect behavior.

Expected Results:  
Widget should be non be in hover state but only enabled state when menu is open just like the bookmarks sidebar and history sidebar widgets.

Bookmark's Context menu should show correct hover state when mouse resting over each menu item.

Either it should not show hover using the default theme for the widget 
Nav Toolbar Bookmark widget hover states should also match the behavior as the Bookmarks Toolbar widget
(Reporter)

Updated

8 years ago
Blocks: 544817
Version: unspecified → Trunk

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

8 years ago
[STR]
1.Start Minefield with crean profile
2.Hide Menu Bar ( View > Toolbars > Menu Bar )
3.Opening new Bookmarks widget (at the far right of Nav Bar)
4.Right click "R" of  "Recently Bookmarked" and open context menu
5.Move mouse onto "Open In New tabs"

(note)
The context menu and the Bookmarks widget menu should be overlapped.
and you must not move mouse pointer outside the region of overlap.

Updated

8 years ago
Depends on: 575162
(Reporter)

Comment 2

8 years ago
V. Fixed by bug 575162.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
No longer depends on: 575162
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 575162
(Reporter)

Comment 4

8 years ago
Thanks, I get confused when something like this is a code fix dupe or just depend fixes wfm.
You need to log in before you can comment on or make changes to this bug.