Debug builds try to load non-existent modules such as libtestdynamic.dylib

RESOLVED DUPLICATE of bug 527458

Status

RESOLVED DUPLICATE of bug 527458
9 years ago
9 months ago

People

(Reporter: jruderman, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
nsNativeModuleLoader::LoadModule("/Users/cltbld/talos-slave/mozilla-central-leopard-debug-u-crashtest/build/MinefieldDebug.app/Contents/MacOS/components/libtestdynamic.dylib") - load FAILED, rv: 80004005, error:
	Unknown error: -2804
nsNativeModuleLoader::LoadModule("/Users/cltbld/talos-slave/mozilla-central-leopard-debug-u-crashtest/build/MinefieldDebug.app/Contents/MacOS/components/libMyService.dylib") - load FAILED, rv: 80004005, error:
	Unknown error: -2804
nsNativeModuleLoader::LoadModule("/Users/cltbld/talos-slave/mozilla-central-leopard-debug-u-crashtest/build/MinefieldDebug.app/Contents/MacOS/components/libxpcomsample.dylib") - load FAILED, rv: 80004005, error:
	Unknown error: -2804
*** Registering components in: nsAlertsServiceModule
nsNativeModuleLoader::LoadModule("/Users/cltbld/talos-slave/mozilla-central-leopard-debug-u-crashtest/build/MinefieldDebug.app/Contents/MacOS/components/libtestcrasher.dylib") - load FAILED, rv: 80004005, error:
	Unknown error: -2804

This doesn't stop Firefox from working, but it does interfere with using gdb to debug debug builds that I have downloaded from Tinderbox.
Probably a dupe of bug 527458. The component loader tries to load everything in components.list. Also, likely to be fixed by bug 568691.
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527458

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.