All open Flash objects crash when specific page with flash object (Scribd) is opened.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Dave Narby, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ( .NET CLR 3.5.30729)

Opening this page http://www.zerohedge.com/article/gold-we-trust-special-report-gold-erste-bank causes all Flash objects to crash.

Bug (unfortunately) seems intermittent, but also isolated to the above page (other Scribd documents do not crash Flash).

Bug started after updating to the latest version of FF and Flash (FF strongly urged I update Flash).  

Everything was fine before the update.



Reproducible: Sometimes

Steps to Reproduce:
1. Surf to http://www.zerohedge.com/article/gold-we-trust-special-report-gold-erste-bank
2.  Wait a few seconds.


Expected Results:  
Flash to work!
(Reporter)

Comment 2

8 years ago
YES!  Changed it to 90, fixed.

Wow.  I would have never guessed that.  Many thanks.

The developers might want to add a feature where if a Flash object takes longer than 10 seconds to load, instead of crashing it for the user (!), it instead brings up a dialog box stating something along the lines of: 

"This Flash application is taking a long time to load, or it may have crashed.  If you no longer want to wait, press this button to reload the page and try again.  Otherwise, you may continue to wait and see if the object successfully loads."

as it stands, 10 seconds is pretty arbitrary and will probably result in millions of false positive crashes.

Comment 3

8 years ago
It's actually not the Scribd bit but the really complex citibank ad (There are two!) that is causing the crash.  It's intermittent because it's on a Google ad rotation.  You can also try an extension like ad block plus.

Comment 4

8 years ago
Ok, I don't get this problem on a really fast machine but I found a 500 MHz PII to test on.

Here are the results:

With 3.6.3, Flash 10.1

Shift-refresh
Page loads (as in text appears) at 5 s
UI is still responsive until 15 s or so
UI is off-and-on, mostly off (occasionally a menu will register a click) until 65 s mark where it works completely.  

With 3.6.4, Flash 10.1 (plugin timeout set to 300 to take it out as a factor)

Shift-refresh
Page load: 5 s
UI stops responding at about 10 s
UI is completely locked up until 70s mark where things work again.

It FEELS slower in 3.6.4 because it locks up a little faster so you don't have time to switch away and do something else while Flash is EATING CPU.

Everything works better when you get the text Google Ads rather than the flash one but it still takes a really really long time to load (didn't do proper test since it's hard to control).  Comment 3 was only partially correct, Scribd is definitely a factor but the other flash ads compound it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

8 years ago
without the workarounds, are you able to repro with FF3.6.6?  i could not repro any crashes or load issues in 10+ tries.
(Reporter)

Comment 6

8 years ago
It may well have to do with connectivity issues.  The Scribd file I originally loaded was quite large, and my connection has been having slowdown issues.  I believe if it was lagging, and took longer than 10s to load, then FF would 'auto crash' Flash.

This https://support.mozilla.com/en-US/kb/The+Adobe+Flash+plugin+has+crashed fixed the issue for me.


As I said before, The developers might want to add a feature where if a Flash object takes longer than 10 seconds to load, instead of crashing it for the user (!), it instead brings up a dialog box stating something along the lines of: 

"This Flash application is taking a long time to load, or it may have crashed. 
If you no longer want to wait, press this button to reload the page and try
again.  Otherwise, you may continue to wait and see if the object successfully
loads."

as it stands, 10 seconds is pretty arbitrary and will probably result in
millions of false positive crashes.

Just my $0.02.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.