Closed Bug 574670 Opened 9 years ago Closed 9 years ago

After switching from default theme to persona, text in search/location bar is hard to see

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- beta2+

People

(Reporter: tanner, Unassigned)

References

Details

(Whiteboard: [Fx3.7Testday])

Attachments

(1 file)

Attached image Screenshot
After you switch from the default theme to a persona, the text in location/search bar is hard to see. It's almost like there's a big shadow behind it.

STR:
1.) Get persona
2.) Switch from default theme to persona
3.) Look at location/search bars

ER:
Text is black, not white

AR:
Text is white, not  black

(See attachment)
With direct2d?
(In reply to comment #1)
> With direct2d?

Yes, i can only reproduce with that enabled. When I disabled direct2d it does work fine.
Blocks: d2d
Component: Theme → Graphics
Product: Firefox → Core
QA Contact: theme → thebes
Whiteboard: [Fx3.7Testday]
Duplicate of this bug: 574742
summary: s/themes/from default theme to persona
Please don't confuse themes and personas, "theme" should still stand for a "heavyweight theme".
Summary: After switching themes, text in search/location bar is hard to see → After switching from default theme to persona, text in search/location bar is hard to see
Duplicate of this bug: 574752
My problem wasn't directly related to having D2D preferences turned on.  It was under default off mode.
Carrying over blocking from bug 574742
blocking2.0: --- → beta2+
This bug works for me now.. must have been fixed with recent nightly but not sure which bug took care of it.  Tested both D2D on/off.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100628 Minefield/3.7a6pre
Reopen if this reoccurs! :)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.