Closed Bug 574683 Opened 12 years ago Closed 12 years ago

Local XUL pages (about:config) are not rendering

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Bug 574260 removed too much. For local XUL pages (browser.contentDocument is not null) we need to keep code that fires MozScrolledAreaChanged or the content will not render.

See about:config

Works with this patch, which adds back just the minimum code. It also checks for a null contentDocument.
Attachment #454039 - Flags: review?(21)
Comment on attachment 454039 [details] [diff] [review]
patch

>+    // Local XUL documents are not firing MozScrolledAreaChanged
>+    let doc = browser.contentDocument;
>+    if (doc && doc instanceof XULDocument) {
>+       let width = doc.documentElement.scrollWidth;
>+       let height = doc.documentElement.scrollHeight;
>+       BrowserView.Util.ensureMozScrolledAreaEvent(browser, width, height);
>+    }
>   },

The indentation looks strange.
Attachment #454039 - Flags: review?(21) → review+
fixed indent

pushed:
http://hg.mozilla.org/mobile-browser/rev/d34f915d9d6a
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Duplicate of this bug: 574712
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/2010630 Namoroka/4.0b2pre Fennec/2.0a1pre


and latest-electrolysis-maemo5-gtk
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → mark.finkle
You need to log in before you can comment on or make changes to this bug.