Firefox is not picking up the language set in Regional Settings

RESOLVED DUPLICATE of bug 285267

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 285267
8 years ago
8 years ago

People

(Reporter: John, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

In regional settings, i have selected French as the language format.  When I attempt to get the client language in javascript (navigator.language) it returns en-US instead of fr-FR.

This seems to work fine on Linux.  Only seeing the issue on Windows.  (also works in IE 8.0

Reproducible: Always

Steps to Reproduce:
1.Change the language in Regional Settings (ex: French)
2.Launch firefox
3.Access the navigator.language variable via javascript
Actual Results:  
navigator.language return en-US

Expected Results:  
should have returned fr-FR

Java is correctly seeing the language as French however the browser is not which is causing issues in our web application.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285267
You need to log in before you can comment on or make changes to this bug.