https through proxy server does not work...

VERIFIED FIXED

Status

()

P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: chakradeo, Assigned: gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Hello,

	The browser sends invalid SSL request to the https proxy while accessing secure
sites. I wrote a small perl program to capture the SSL request sent by
netscape4.75 and then by mozilla Build Id 2000101014 (WinNT), PSM version 1.3:

Using Netscape 4.75, the request goes like:
CONNECT investment.datek.com:443 HTTP/1.0
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)


and using Mozilla, the request goes like:
GET https://investment.datek.com/ HTTP/1.1
Referer: https://investment.datek.com/
Host: investment.datek.com
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001010
Accept: */*
Accept-Language: en
Accept-Encoding: gzip,deflate,compress,identity
Keep-Alive: 300
Connection: keep-alive


I would like to add that I could access https sites inside the firewall
correctly using mozilla.

Boohoo
Amit

Boohoo..
(Reporter)

Comment 1

18 years ago
Before you treat this as a yet another duplicate of bad error message when PSM
isn't installed, I would like to add that I have PSM installed and it works for
https sites inside firewall...

Comment 2

18 years ago
Browser->Networking
Assignee: lord → gagan
Component: Daemon → Networking
Product: PSM → Browser
QA Contact: nitinp → tever
Version: 1.3 → other

Comment 3

18 years ago
chakradeo, could you try a newer build please.  This should have been fixed 
around 10/19.  (see bug 31174)
(Reporter)

Comment 4

18 years ago
I downloaded the current nightly build for winnt, and it is possible to connect
to *some* ssl sites. But it (I believe it's just PSM, because mozilla still
works and connects to normal sites) crashes for some sites. e.g.
https://www.sdccu.org/

Comment 5

18 years ago
Marking fixed as the original bug is fixed. Please open a new bug if you are
having different problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.